summaryrefslogtreecommitdiffstats
path: root/package/pppd
diff options
context:
space:
mode:
authorHamish Moffatt <hamish@cloud.net.au>2009-02-19 05:31:05 +0000
committerHamish Moffatt <hamish@cloud.net.au>2009-02-19 05:31:05 +0000
commita83dddf9ff22cf160dba9f4ecf21ba7b36d0ba69 (patch)
treea2ec39167031f3af869631c03ad2a694b3a8feb0 /package/pppd
parentea74003ebf5288c83a839d335c06160d4860eba9 (diff)
downloadbuildroot-novena-a83dddf9ff22cf160dba9f4ecf21ba7b36d0ba69.tar.gz
buildroot-novena-a83dddf9ff22cf160dba9f4ecf21ba7b36d0ba69.zip
Enable multilink PPP (no reason to disable it)
Add configuration item to enable filtering (requires libpcap)
Diffstat (limited to 'package/pppd')
-rw-r--r--package/pppd/Config.in10
-rw-r--r--package/pppd/pppd.mk8
2 files changed, 15 insertions, 3 deletions
diff --git a/package/pppd/Config.in b/package/pppd/Config.in
index 584bb981c..960640d05 100644
--- a/package/pppd/Config.in
+++ b/package/pppd/Config.in
@@ -4,3 +4,13 @@ config BR2_PACKAGE_PPPD
An implementation of the Point-to-point protocol.
http://www.samba.org/ppp/
+
+config BR2_PACKAGE_PPPD_FILTER
+ depends on BR2_PACKAGE_PPPD
+ select BR2_PACKAGE_LIBPCAP
+ bool "filtering"
+ help
+ Packet filtering abilities for pppd. If enabled,
+ the pppd active-filter and pass-filter options
+ are available.
+
diff --git a/package/pppd/pppd.mk b/package/pppd/pppd.mk
index abe26649d..1099cd52b 100644
--- a/package/pppd/pppd.mk
+++ b/package/pppd/pppd.mk
@@ -17,15 +17,17 @@ $(DL_DIR)/$(PPPD_SOURCE):
pppd-source: $(DL_DIR)/$(PPPD_SOURCE)
+PPPD_OPTIONS_$(BR2_PACKAGE_PPPD_FILTER) += FILTER=y
+
$(PPPD_DIR)/.unpacked: $(DL_DIR)/$(PPPD_SOURCE)
$(PPPD_CAT) $(DL_DIR)/$(PPPD_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
$(SED) 's/ -DIPX_CHANGE -DHAVE_MMAP//' $(PPPD_DIR)/pppd/Makefile.linux
- $(SED) 's/HAVE_MULTILINK=y/#HAVE_MULTILINK=y/' $(PPPD_DIR)/pppd/Makefile.linux
$(SED) 's/FILTER=y/#FILTER=y/' $(PPPD_DIR)/pppd/Makefile.linux
$(SED) 's,(INSTALL) -s,(INSTALL),' $(PPPD_DIR)/*/Makefile.linux
$(SED) 's,(INSTALL) -s,(INSTALL),' $(PPPD_DIR)/pppd/plugins/*/Makefile.linux
$(SED) 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
$(SED) 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
+ $(SED) 's/ifneq ($$(wildcard \/usr\/include\/pcap-bpf.h),)/ifdef FILTER/' $(PPPD_DIR)/*/Makefile.linux
touch $@
$(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked
@@ -52,10 +54,10 @@ $(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked
touch $@
$(PPPD_DIR)/$(PPPD_BINARY): $(PPPD_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) COPTS="$(TARGET_CFLAGS)" -C $(PPPD_DIR)
+ $(MAKE) CC=$(TARGET_CC) COPTS="$(TARGET_CFLAGS)" -C $(PPPD_DIR) $(PPPD_OPTIONS_y)
$(TARGET_DIR)/$(PPPD_TARGET_BINARY): $(PPPD_DIR)/$(PPPD_BINARY)
- $(MAKE1) DESTDIR=$(TARGET_DIR)/usr CC=$(TARGET_CC) -C $(PPPD_DIR) install
+ $(MAKE1) DESTDIR=$(TARGET_DIR)/usr CC=$(TARGET_CC) -C $(PPPD_DIR) install $(PPPD_OPTIONS_y)
ifneq ($(BR2_ENABLE_LOCALE),y)
rm -rf $(TARGET_DIR)/usr/share/locale
endif