summaryrefslogtreecommitdiffstats
path: root/package/portmap/portmap.mk
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-01-14 00:55:25 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-01-14 00:55:25 +0000
commit2f2492f7f193885bb13f13805e2f703474018b95 (patch)
tree049736e190342ed008441efdcf68f6b7c5b1d472 /package/portmap/portmap.mk
parentba46d6ef76fee525001aebec7ae78f6dbd89ac23 (diff)
downloadbuildroot-novena-2f2492f7f193885bb13f13805e2f703474018b95.tar.gz
buildroot-novena-2f2492f7f193885bb13f13805e2f703474018b95.zip
Update packages to provide properly working initialization scripts. These have been tested with embedded PowerPC systems.
Diffstat (limited to 'package/portmap/portmap.mk')
-rw-r--r--package/portmap/portmap.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/portmap/portmap.mk b/package/portmap/portmap.mk
index 001ecbb43..29fdc2927 100644
--- a/package/portmap/portmap.mk
+++ b/package/portmap/portmap.mk
@@ -25,12 +25,14 @@ $(PORTMAP_DIR)/$(PORTMAP_BINARY): $(PORTMAP_DIR)/.unpacked
$(MAKE) CC=$(TARGET_CC) O="$(TARGET_CFLAGS)" -C $(PORTMAP_DIR)
$(TARGET_DIR)/$(PORTMAP_TARGET_BINARY): $(PORTMAP_DIR)/$(PORTMAP_BINARY)
- install -D $(PORTMAP_DIR)/$(PORTMAP_BINARY) $(TARGET_DIR)/$(PORTMAP_TARGET_BINARY)
+ $(INSTALL) -D $(PORTMAP_DIR)/$(PORTMAP_BINARY) $(TARGET_DIR)/$(PORTMAP_TARGET_BINARY)
+ $(INSTALL) -m 0755 -D package/portmap/init-portmap $(TARGET_DIR)/etc/init.d/S13portmap
portmap: uclibc $(TARGET_DIR)/$(PORTMAP_TARGET_BINARY)
portmap-clean:
rm -f $(TARGET_DIR)/$(PORTMAP_TARGET_BINARY)
+ rm -f $(TARGET_DIR)/etc/init.d/S13portmap
-$(MAKE) -C $(PORTMAP_DIR) clean
portmap-dirclean: