summaryrefslogtreecommitdiffstats
path: root/package/popt
diff options
context:
space:
mode:
authorNigel Kukard <nkukard@lbsd.net>2008-04-12 09:51:21 +0000
committerNigel Kukard <nkukard@lbsd.net>2008-04-12 09:51:21 +0000
commit9fadf8ade54a79427a8ac712e9de974c77bf02fc (patch)
treeafa07d5fc02c38e9724bcdc2ab92ae579eb73ce5 /package/popt
parentd114386c45ca4ae4009dd8b5cee181370ff0f814 (diff)
downloadbuildroot-novena-9fadf8ade54a79427a8ac712e9de974c77bf02fc.tar.gz
buildroot-novena-9fadf8ade54a79427a8ac712e9de974c77bf02fc.zip
* Added popt
Diffstat (limited to 'package/popt')
-rw-r--r--package/popt/Config.in7
-rw-r--r--package/popt/popt-1.14_no-wchar.patch12
-rw-r--r--package/popt/popt.mk20
3 files changed, 39 insertions, 0 deletions
diff --git a/package/popt/Config.in b/package/popt/Config.in
new file mode 100644
index 000000000..4e59fcf63
--- /dev/null
+++ b/package/popt/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_POPT
+ bool "popt"
+ default n
+ help
+ Popt is a C library for parsing command line parameters.
+
+ http://rpm5.org
diff --git a/package/popt/popt-1.14_no-wchar.patch b/package/popt/popt-1.14_no-wchar.patch
new file mode 100644
index 000000000..161165e72
--- /dev/null
+++ b/package/popt/popt-1.14_no-wchar.patch
@@ -0,0 +1,12 @@
+diff -ru popt-1.14_vanilla/popthelp.c popt-1.14_no-wchar/popthelp.c
+--- popt-1.14_vanilla/popthelp.c 2008-03-27 17:33:08.000000000 +0000
++++ popt-1.14_no-wchar/popthelp.c 2008-04-10 05:44:43.000000000 +0000
+@@ -15,7 +15,7 @@
+ #include <sys/ioctl.h>
+ #endif
+
+-#define POPT_WCHAR_HACK
++/* #define POPT_WCHAR_HACK */
+ #ifdef POPT_WCHAR_HACK
+ #include <wchar.h> /* for mbsrtowcs */
+ /*@access mbstate_t @*/
diff --git a/package/popt/popt.mk b/package/popt/popt.mk
new file mode 100644
index 000000000..31399e434
--- /dev/null
+++ b/package/popt/popt.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# popt
+#
+#############################################################
+POPT_VERSION = 1.14
+POPT_SITE = http://rpm5.org/files/popt
+POPT_INSTALL_STAGING = YES
+
+
+POPT_CONF_ENV = ac_cv_va_copy=yes
+
+
+POPT_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(REAL_GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) --prefix=/usr
+
+POPT_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
+
+
+$(eval $(call AUTOTARGETS,package,popt))