summaryrefslogtreecommitdiffstats
path: root/package/polarssl
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-11-17 06:42:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-17 22:08:00 +0100
commitb5a34e750f25cd97b1717c7cf56d0e90d6b0f895 (patch)
tree33846545c6986a117a13c3dc5f49a34cec32bb11 /package/polarssl
parent7451db3d3aed29c65b7c9acfc880536b381ce1dd (diff)
downloadbuildroot-novena-b5a34e750f25cd97b1717c7cf56d0e90d6b0f895.tar.gz
buildroot-novena-b5a34e750f25cd97b1717c7cf56d0e90d6b0f895.zip
polarssl: bump to version 1.2.0
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/polarssl')
-rw-r--r--package/polarssl/polarssl-shared-and-static-library.patch19
-rw-r--r--package/polarssl/polarssl.mk6
2 files changed, 15 insertions, 10 deletions
diff --git a/package/polarssl/polarssl-shared-and-static-library.patch b/package/polarssl/polarssl-shared-and-static-library.patch
index 562b9005a..e11cab3f5 100644
--- a/package/polarssl/polarssl-shared-and-static-library.patch
+++ b/package/polarssl/polarssl-shared-and-static-library.patch
@@ -9,21 +9,22 @@ This patch adds the USE_STATIC_POLARSSL_LIBRARY (which defaults to ON)
in addition to the existing USE_SHARED_POLARSSL_LIBRARY (which
defaults to OFF). Both options can be manipulated independently.
+[Gustavo: update for polarssl 1.2.0]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-Index: polarssl-1.1.1/library/CMakeLists.txt
-===================================================================
---- polarssl-1.1.1.orig/library/CMakeLists.txt
-+++ polarssl-1.1.1/library/CMakeLists.txt
+diff -Nura polarssl-1.2.0.orig/library/CMakeLists.txt polarssl-1.2.0/library/CMakeLists.txt
+--- polarssl-1.2.0.orig/library/CMakeLists.txt 2012-11-15 15:01:58.239248830 -0300
++++ polarssl-1.2.0/library/CMakeLists.txt 2012-11-15 15:00:10.310806353 -0300
@@ -1,4 +1,5 @@
option(USE_SHARED_POLARSSL_LIBRARY "Build PolarSSL as a shared library." OFF)
+option(USE_STATIC_POLARSSL_LIBRARY "Build PolarSSL as a static library." ON)
set(src
aes.c
-@@ -40,17 +41,21 @@
- xtea.c
- )
+@@ -50,19 +51,23 @@
+ set(libs ws2_32)
+ endif(WIN32)
-if(NOT USE_SHARED_POLARSSL_LIBRARY)
-
@@ -33,7 +34,7 @@ Index: polarssl-1.1.1/library/CMakeLists.txt
+if(USE_SHARED_POLARSSL_LIBRARY)
add_library(polarssl SHARED ${src})
- set_target_properties(polarssl PROPERTIES VERSION 1.1.3 SOVERSION 1)
+ set_target_properties(polarssl PROPERTIES VERSION 1.2.0 SOVERSION 2)
+set_target_properties(polarssl PROPERTIES OUTPUT_NAME polarssl)
+
+endif(USE_SHARED_POLARSSL_LIBRARY)
@@ -46,6 +47,8 @@ Index: polarssl-1.1.1/library/CMakeLists.txt
-endif(NOT USE_SHARED_POLARSSL_LIBRARY)
+endif(USE_STATIC_POLARSSL_LIBRARY)
+ target_link_libraries(polarssl ${libs})
+
-install(TARGETS polarssl
+install(TARGETS polarssl polarssl-static
DESTINATION ${LIB_INSTALL_DIR}
diff --git a/package/polarssl/polarssl.mk b/package/polarssl/polarssl.mk
index 34fbe293b..edda9bfa3 100644
--- a/package/polarssl/polarssl.mk
+++ b/package/polarssl/polarssl.mk
@@ -1,5 +1,5 @@
-POLARSSL_SITE = http://polarssl.org/code/releases/
-POLARSSL_VERSION = 1.1.4
+POLARSSL_SITE = https://polarssl.org/download
+POLARSSL_VERSION = 1.2.0
POLARSSL_SOURCE = polarssl-$(POLARSSL_VERSION)-gpl.tgz
POLARSSL_CONF_OPT = \
-DUSE_SHARED_POLARSSL_LIBRARY=ON \
@@ -8,6 +8,8 @@ POLARSSL_CONF_OPT = \
-DBUILD_PROGRAMS=$(if $(BR2_PACKAGE_POLARSSL_PROGRAMS),ON,OFF)
POLARSSL_INSTALL_STAGING = YES
+POLARSSL_LICENSE = GPLv2
+POLARSSL_LICENSE_FILES = LICENSE
$(eval $(cmake-package))