summaryrefslogtreecommitdiffstats
path: root/package/polarssl/polarssl-no-test-suite.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-10 18:05:28 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-15 09:15:17 +0200
commit31993b329ee676d9f0bece894eee39b1243cfd90 (patch)
treeaecb3d1a3ebc758bf16c1b11b2af88959e606f7e /package/polarssl/polarssl-no-test-suite.patch
parentb163ca39320e54192102218ee137b13b7828695e (diff)
downloadbuildroot-novena-31993b329ee676d9f0bece894eee39b1243cfd90.tar.gz
buildroot-novena-31993b329ee676d9f0bece894eee39b1243cfd90.zip
polarssl: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/polarssl/polarssl-no-test-suite.patch')
-rw-r--r--package/polarssl/polarssl-no-test-suite.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/polarssl/polarssl-no-test-suite.patch b/package/polarssl/polarssl-no-test-suite.patch
new file mode 100644
index 000000000..7e0744132
--- /dev/null
+++ b/package/polarssl/polarssl-no-test-suite.patch
@@ -0,0 +1,26 @@
+Add BUILD_TESTS option to disable test suite
+
+By default, PolarSSL builds a fairly extensive test suite to validate
+the library. In the context of Buildroot, building this test suite is
+not really useful, so we add a BUILD_TESTS to disable its build.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: polarssl-1.1.1/CMakeLists.txt
+===================================================================
+--- polarssl-1.1.1.orig/CMakeLists.txt
++++ polarssl-1.1.1/CMakeLists.txt
+@@ -27,9 +27,11 @@
+ add_subdirectory(library)
+ add_subdirectory(include)
+
+-if(CMAKE_COMPILER_IS_GNUCC)
++option(BUILD_TESTS "Build tests." ON)
++
++if(CMAKE_COMPILER_IS_GNUCC AND BUILD_TESTS)
+ add_subdirectory(tests)
+-endif(CMAKE_COMPILER_IS_GNUCC)
++endif(CMAKE_COMPILER_IS_GNUCC AND BUILD_TESTS)
+
+ add_subdirectory(programs)
+