summaryrefslogtreecommitdiffstats
path: root/package/pmake
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-05-14 11:45:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-30 22:33:05 +0200
commit3e037134a4d4e0429a413e80f345291118e8157d (patch)
tree984ecb43aa6a675ff3d292b3c2cb0245dd3ef6ba /package/pmake
parentac23d50496d590026fe5ae140bc5e98e72f208e3 (diff)
downloadbuildroot-novena-3e037134a4d4e0429a413e80f345291118e8157d.tar.gz
buildroot-novena-3e037134a4d4e0429a413e80f345291118e8157d.zip
package/pmake: force argv[0]=${0} in the pmake wrapper
This forces bmake to call the wrapper, not itself. Also, use consistent "${0/*}" instead of "${0/pmake}". Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pmake')
-rw-r--r--package/pmake/pmake.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pmake/pmake.mk b/package/pmake/pmake.mk
index 7b2e5a6ef..50613e8d4 100644
--- a/package/pmake/pmake.mk
+++ b/package/pmake/pmake.mk
@@ -39,7 +39,7 @@ define HOST_PMAKE_INSTALL_CMDS
for mk in $(@D)/mk/*; do \
$(INSTALL) -m 0644 $${mk} $(HOST_DIR)/usr/share/pmake/mk; \
done
- printf '#!/bin/sh\nexec $${0%%/*}/bmake -m $${0%%/pmake}/../../usr/share/pmake/mk "$$@"\n' \
+ printf '#!/bin/bash\nexec -a "$${0}" $${0%%/*}/bmake -m $${0%%/*}/../../usr/share/pmake/mk "$$@"\n' \
>$(HOST_DIR)/usr/bin/pmake
chmod 0755 $(HOST_DIR)/usr/bin/pmake
endef