summaryrefslogtreecommitdiffstats
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-05 10:52:18 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-05 10:58:40 +0200
commit31aa4264d8839d05684e67a238837e8633d1e1bc (patch)
tree6514b5561369a8cbe77381599d46ea88c416d5f0 /package/pkg-utils.mk
parenta13afc11456e38ccbb49d3e70297118e8e9f8cae (diff)
downloadbuildroot-novena-31aa4264d8839d05684e67a238837e8633d1e1bc.tar.gz
buildroot-novena-31aa4264d8839d05684e67a238837e8633d1e1bc.zip
pkg-utils.mk: legal-license-file: handle multiple license files with same name
Some packages (kmod, e2fsprogs, ..) contain multiple (different) license files with the same file name, but in different directories. These are currently all copied to the same filename in output/legal-info/licenses/<pkg>, overwriting everything but the last file. Fix it by recreating the same directory structure under legal-info. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 835c588af..86d687fb9 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -106,6 +106,6 @@ define legal-license-file # pkg, filename, file-fullpath
$(call legal-license-header,$(1),$(2) file) && \
cat $(3) >>$(LEGAL_LICENSES_TXT) && \
echo >>$(LEGAL_LICENSES_TXT) && \
- mkdir -p $(LICENSE_FILES_DIR)/$(1)/ && \
- cp $(3) $(LICENSE_FILES_DIR)/$(1)/
+ mkdir -p $(LICENSE_FILES_DIR)/$(1)/$(dir $(2)) && \
+ cp $(3) $(LICENSE_FILES_DIR)/$(1)/$(2)
endef