summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorStephan Hoffmann <sho@relinux.de>2012-12-03 00:05:51 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-05 11:29:37 -0800
commit7f77121fdde5a0c16d9b6968c71e982d3e953d25 (patch)
tree8e8a67510a6a6e78315c1f5e1f85ff53069c7c9f /package/pkg-generic.mk
parent907ff8983e51046cd9fddd884440e83545a38088 (diff)
downloadbuildroot-novena-7f77121fdde5a0c16d9b6968c71e982d3e953d25.tar.gz
buildroot-novena-7f77121fdde5a0c16d9b6968c71e982d3e953d25.zip
make legal-info: fails with OVERRIDE_SRCDIR
There is a check for OVERRIDE_SRCDIR in pkg-generic.mk that is supposed to produce a warning when OVERRIDE_SRCDIR is active. This does not work and instead the whole make terminates with an error message. This patch changes the check for active OVERRIDE_SRCDIR so that it works as expected. Signed-off-by: Stephan Hoffmann <sho@relinux.de> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 6fcd359ee..fc05dc66b 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -477,7 +477,7 @@ ifneq ($(call qstrip,$$($(2)_SOURCE)),)
ifeq ($$($(2)_SITE_METHOD),local)
# Packages without a tarball: don't save and warn
@$(call legal-warning-pkg-savednothing,$$($(2)_RAWNAME),local)
-else ifeq ($$($(2)_SITE_METHOD),override)
+else ifneq ($$($(2)_OVERRIDE_SRCDIR),)
@$(call legal-warning-pkg-savednothing,$$($(2)_RAWNAME),override)
else
# Other packages