summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-10-14 05:17:34 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-15 10:21:33 +0200
commit79bfcd556027901b847cae063cbcfbedf75e394a (patch)
tree9997e0198190d4473b024370069f51c8204e58e9 /package/pkg-generic.mk
parent260a5820180760d4b00e530041d98eab4bab60fc (diff)
downloadbuildroot-novena-79bfcd556027901b847cae063cbcfbedf75e394a.tar.gz
buildroot-novena-79bfcd556027901b847cae063cbcfbedf75e394a.zip
pkg-infra: correct the source name for host-only packages
Host-only package that don't define their <PKG>_SOURCE variable would default to host-<pkg>-<version>.tar.gz. It's more logical to remove the host- prefix in this case. This problem is most apparent with host-only packages downloaded from version control, because they never define <PKG>_SOURCE. Reported by Thomas Petazzoni and initial analysis by Luca Ceresoli. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index ffe7dfbc5..270da60c6 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -231,7 +231,7 @@ ifndef $(2)_SOURCE
ifdef $(3)_SOURCE
$(2)_SOURCE = $($(3)_SOURCE)
else
- $(2)_SOURCE ?= $$($(2)_BASE_NAME).tar.gz
+ $(2)_SOURCE ?= $$($(2)_RAWNAME)-$$($(2)_VERSION).tar.gz
endif
endif