summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2013-03-01 10:26:38 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-17 14:40:23 +0100
commit3b681efa4c2910c020662c1510efb4ee17008a17 (patch)
tree4c9046814d40458de35abb978b517900f2ed535e /package/pkg-generic.mk
parent58917a65dc6ec987621fc07c865322cdef0ddb7f (diff)
downloadbuildroot-novena-3b681efa4c2910c020662c1510efb4ee17008a17.tar.gz
buildroot-novena-3b681efa4c2910c020662c1510efb4ee17008a17.zip
<pkg>-rsync: exclude version control files
When using rsync to import package sources (typically with PKG_OVERRIDE_SRCDIR), it often happens that these external sources are under version control, and contain directories like .git, .hg, etc. Depending on the project, these directories can become pretty large and typically have a lot of files. Moreover, they are not necessary in the context of building the package. Therefore, this commit adds the --cvs-exclude option to the rsync call, saving both disk space and sync time. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 57b0fd08c..8d964a18c 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -62,7 +62,7 @@ $(BUILD_DIR)/%/.stamp_extracted:
$(BUILD_DIR)/%/.stamp_rsynced:
@$(call MESSAGE,"Syncing from source dir $(SRCDIR)")
@test -d $(SRCDIR) || (echo "ERROR: $(SRCDIR) does not exist" ; exit 1)
- rsync -au $(SRCDIR)/ $(@D)
+ rsync -au --cvs-exclude $(SRCDIR)/ $(@D)
$(Q)touch $@
# Handle the SOURCE_CHECK and SHOW_EXTERNAL_DEPS cases for rsynced