summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorShawn J. Goff <shawn7400@gmail.com>2013-04-12 09:40:30 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-15 20:33:52 +0200
commit1cbffbd015106ea90fe49e27433375769dc1035b (patch)
tree9868e930e6ad567dcbc62f2247511da39357d084 /package/pkg-generic.mk
parentc24e66a3ee4d8933d21fe0e6207a6a9aec12ba81 (diff)
downloadbuildroot-novena-1cbffbd015106ea90fe49e27433375769dc1035b.tar.gz
buildroot-novena-1cbffbd015106ea90fe49e27433375769dc1035b.zip
eliminate double slashes caused by FOO_SITE ending in a slash
When a FOO_SITE variable ends in a slash and gets joined with a FOO_SOURCE variable like $(FOO_SITE)/$(FOO_SOURCE), the resulting URI has a double slash. While double-slashes are fine in unix paths, they are reserved in URIs - the part following '//' must be an authority. Signed-off-by: Shawn J. Goff <shawn7400@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 901bcf7ba..e6bc95599 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -39,8 +39,8 @@ ifeq ($(DL_MODE),DOWNLOAD)
done ; \
fi
endif
- $(if $($(PKG)_SOURCE),$(call DOWNLOAD,$($(PKG)_SITE)/$($(PKG)_SOURCE)))
- $(foreach p,$($(PKG)_PATCH),$(call DOWNLOAD,$($(PKG)_SITE)/$(p))$(sep))
+ $(if $($(PKG)_SOURCE),$(call DOWNLOAD,$($(PKG)_SITE:/=)/$($(PKG)_SOURCE)))
+ $(foreach p,$($(PKG)_PATCH),$(call DOWNLOAD,$($(PKG)_SITE:/=)/$(p))$(sep))
$(foreach hook,$($(PKG)_POST_DOWNLOAD_HOOKS),$(call $(hook))$(sep))
ifeq ($(DL_MODE),DOWNLOAD)
$(Q)mkdir -p $(@D)