summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorAndreas Naumann <dev@andin.de>2013-03-22 16:56:54 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 22:07:56 +0100
commit1539efc5d525641a9ac13a6c96bea7fdd45ed183 (patch)
tree558f9c594021ebe38980c2f9c807123e325f1ffa /package/pkg-generic.mk
parent7b252919409e7bb63f6035fbe3b7167f4abbfed1 (diff)
downloadbuildroot-novena-1539efc5d525641a9ac13a6c96bea7fdd45ed183.tar.gz
buildroot-novena-1539efc5d525641a9ac13a6c96bea7fdd45ed183.zip
<pkg>-rsync: Reincluding core files and folders, which got kicked out by --cvs-exclude option.
The --cvs-exclude option also excludes 'core', which when rsyncing e.g. a linux tree is less than optimal.. Signed-off-by: Andreas Naumann <anaumann@ultratronik.de> Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Tested-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index afb90bf79..901bcf7ba 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -62,7 +62,7 @@ $(BUILD_DIR)/%/.stamp_extracted:
$(BUILD_DIR)/%/.stamp_rsynced:
@$(call MESSAGE,"Syncing from source dir $(SRCDIR)")
@test -d $(SRCDIR) || (echo "ERROR: $(SRCDIR) does not exist" ; exit 1)
- rsync -au --cvs-exclude $(SRCDIR)/ $(@D)
+ rsync -au --cvs-exclude --include core $(SRCDIR)/ $(@D)
$(Q)touch $@
# Handle the SOURCE_CHECK and SHOW_EXTERNAL_DEPS cases for rsynced