summaryrefslogtreecommitdiffstats
path: root/package/pkg-download.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-17 16:45:20 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-19 16:08:09 +0200
commitc0e6b52482f244e5da6e8011d1737b0a21cef207 (patch)
treea5a89a9d177050828b3afd421d5f323e5de6dc7b /package/pkg-download.mk
parent6e6b99a5714834c9330c30dd3af04009f5713204 (diff)
downloadbuildroot-novena-c0e6b52482f244e5da6e8011d1737b0a21cef207.tar.gz
buildroot-novena-c0e6b52482f244e5da6e8011d1737b0a21cef207.zip
pkg-*.mk: add some comments, update some existing comments
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-download.mk')
-rw-r--r--package/pkg-download.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index a565ae696..ccf819e3d 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -1,3 +1,12 @@
+############################################################################
+#
+# This file contains the download helpers for the various package
+# infrastructures. It is used to handle downloads from HTTP servers,
+# FTP servers, Git repositories, Subversion repositories, Mercurial
+# repositories, Bazaar repositories, and SCP servers.
+#
+############################################################################
+
# Download method commands
WGET:=$(call qstrip,$(BR2_WGET)) $(QUIET)
SVN:=$(call qstrip,$(BR2_SVN))