summaryrefslogtreecommitdiffstats
path: root/package/pkg-download.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2012-06-22 07:42:34 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-22 16:53:24 +0200
commit060312567323024ec6fd90e4cec1485816cec811 (patch)
treeb7aff7e339fc1f521794c3fabd19fcb9fc99c7f0 /package/pkg-download.mk
parent3afc90c7d7667d698fb7b470ea77d6a7010d7696 (diff)
downloadbuildroot-novena-060312567323024ec6fd90e4cec1485816cec811.tar.gz
buildroot-novena-060312567323024ec6fd90e4cec1485816cec811.zip
pkg-download.mk: allow using localfiles outside of package infrastructure
The localfiles download method uses $($(PKG)_SITE))) and $($(PKG)_SOURCE) instead of $(1) and $(2). This means that it can only be used for package downloads (through gentargets, autotargets, ...) and not for other downloads like external toolchains. This patch changes localfiles to allow this, just as the wget and scp download methods already did. For the version control download methods, nothing changes. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-download.mk')
-rw-r--r--package/pkg-download.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index 79837060b..fb5154076 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -177,16 +177,16 @@ define SHOW_EXTERNAL_DEPS_WGET
endef
define DOWNLOAD_LOCALFILES
- test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
- $(LOCALFILES) $(call qstrip,$(subst file://,,$($(PKG)_SITE)))/$($(PKG)_SOURCE) $(DL_DIR)
+ test -e $(DL_DIR)/$(2) || \
+ $(LOCALFILES) $(call qstrip,$(subst file://,,$(1))) $(DL_DIR)
endef
define SOURCE_CHECK_LOCALFILES
- test -e $(call qstrip,$(subst file://,,$($(PKG)_SITE)))/$($(PKG)_SOURCE)
+ test -e $(call qstrip,$(subst file://,,$(1)))
endef
define SHOW_EXTERNAL_DEPS_LOCALFILES
- echo $($(PKG)_SITE)/$($(PKG)_SOURCE)
+ echo $(2)
endef
################################################################################