summaryrefslogtreecommitdiffstats
path: root/package/pkg-config
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2010-12-26 17:16:35 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-28 20:33:20 +0100
commita68640c31dbf216eb5862d76daefce4b7e754795 (patch)
treee5710662cb4cc117b55a4d2be84ebf961349684a /package/pkg-config
parent58ddf43464ab3892d2af0c3973e6d9ef31653fdf (diff)
downloadbuildroot-novena-a68640c31dbf216eb5862d76daefce4b7e754795.tar.gz
buildroot-novena-a68640c31dbf216eb5862d76daefce4b7e754795.zip
package: avoid copying .m4 files from host to staging
Since we are preparing a package generation mechanism, we would like to avoid packages that move/touch/modify files which are not part of their own package. That's why we try to not install host files into the staging directory (in this case .m4 files) and instead we include $(HOST_DIR)/usr/share/aclocal into autoreconf search directory. Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-config')
-rw-r--r--package/pkg-config/pkg-config.mk7
1 files changed, 0 insertions, 7 deletions
diff --git a/package/pkg-config/pkg-config.mk b/package/pkg-config/pkg-config.mk
index 330b16603..d0bc42478 100644
--- a/package/pkg-config/pkg-config.mk
+++ b/package/pkg-config/pkg-config.mk
@@ -15,13 +15,6 @@ HOST_PKG_CONFIG_CONF_OPT = \
--with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig" \
--disable-static
-define HOST_PKG_CONFIG_INSTALL_M4
-install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/pkg.m4 \
- $(STAGING_DIR)/usr/share/aclocal/pkg.m4
-endef
-
-HOST_PKG_CONFIG_POST_INSTALL_HOOKS += HOST_PKG_CONFIG_INSTALL_M4
-
$(eval $(call AUTOTARGETS,package,pkg-config))
$(eval $(call AUTOTARGETS,package,pkg-config,host))