summaryrefslogtreecommitdiffstats
path: root/package/pkg-autotools.mk
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2012-07-22 15:28:34 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-22 19:28:42 +0200
commit9ba9bfb9a02706fa414bcf4c6dcceac1b68a5c9a (patch)
treeb6bfff8da9eadf0cac6874766ec47d58559f92dd /package/pkg-autotools.mk
parent736ce2f3da29558544a38b0404e0c4ff4d41c9ac (diff)
downloadbuildroot-novena-9ba9bfb9a02706fa414bcf4c6dcceac1b68a5c9a.tar.gz
buildroot-novena-9ba9bfb9a02706fa414bcf4c6dcceac1b68a5c9a.zip
pkg-*targets.mk: factorize and fix $(PKG)_SRCDIR and $(PKG)_BUILDDIR declaration
Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-autotools.mk')
-rw-r--r--package/pkg-autotools.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index e4540509d..785daab0e 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -54,15 +54,6 @@ endef
define inner-autotools-package
-# define package-specific variables to default values
-ifndef $(2)_SUBDIR
- ifdef $(3)_SUBDIR
- $(2)_SUBDIR = $($(3)_SUBDIR)
- else
- $(2)_SUBDIR ?=
- endif
-endif
-
ifndef $(2)_LIBTOOL_PATCH
ifdef $(3)_LIBTOOL_PATCH
$(2)_LIBTOOL_PATCH = $($(3)_LIBTOOL_PATCH)
@@ -91,7 +82,6 @@ $(2)_CLEAN_OPT ?= clean
$(2)_UNINSTALL_STAGING_OPT ?= DESTDIR=$$(STAGING_DIR) uninstall
$(2)_UNINSTALL_TARGET_OPT ?= DESTDIR=$$(TARGET_DIR) uninstall
-$(2)_SRCDIR = $$($(2)_DIR)/$$($(2)_SUBDIR)
#
# Configure step. Only define it if not already defined by the package