summaryrefslogtreecommitdiffstats
path: root/package/pkg-autotools.mk
diff options
context:
space:
mode:
authorprzemyslaw <przemyslaw.wrzos@calyptech.com>2013-03-20 20:09:42 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 22:15:58 +0100
commit3400663620e039427c704f6c73b061d23ac54a4a (patch)
tree766c8a2d506adea0128db2eff335fb92bbcedce0 /package/pkg-autotools.mk
parent9a1f303ea24075d8d2f2388452cec965591d5e57 (diff)
downloadbuildroot-novena-3400663620e039427c704f6c73b061d23ac54a4a.tar.gz
buildroot-novena-3400663620e039427c704f6c73b061d23ac54a4a.zip
Fix autoreconf libtool patching
Some ltmain.sh files enclose the version number in quotes. This is already handled corretly by pkg-autotools.mk in LIBTOOL_PATCH_HOOK. This patch adds the same fix for AUTORECONF_HOOK. Signed-off-by: przemyslaw <przemyslaw.wrzos@calyptech.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pkg-autotools.mk')
-rw-r--r--package/pkg-autotools.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index 995c68596..d8d7e6d47 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -185,7 +185,8 @@ define AUTORECONF_HOOK
$(Q)cd $$($$(PKG)_SRCDIR) && $(AUTORECONF) $$($$(PKG)_AUTORECONF_OPT)
$(Q)if test "$$($$(PKG)_LIBTOOL_PATCH)" = "YES"; then \
for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
- ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$$$i | sed 's/\([0-9].[0-9]*\).*/\1/'`; \
+ ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$$$i | \
+ sed -e 's/\([0-9].[0-9]*\).*/\1/' -e 's/\"//'`; \
if test $$$${ltmain_version} = "1.5"; then \
support/scripts/apply-patches.sh $$$${i%/*} support/libtool buildroot-libtool-v1.5.patch; \
elif test $$$${ltmain_version} = "2.2"; then\