summaryrefslogtreecommitdiffstats
path: root/package/pixman
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
commite7b38c71ce55720f7709f0049f5bfc71ca0615ec (patch)
tree2ce70187ad1380f02c1777e7da3a48fb16d9f26a /package/pixman
parentf58ff9a25f24576e032c65d762e5b8fdd2cf5c1c (diff)
downloadbuildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.tar.gz
buildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.zip
package: add STAMP_DIR and use for host builds
Move stamp (dependency) files outside the (version specific) source directories, so other packages can hardcode dependencies on them instead of having to use <PACKAGE>_VERSION variables. This is important as the variables in the make rules are evaluated when the rules is seen, which might be before the dependent makefile is parsed (and hence <PACKAGE>_VERSION variable is known, screwing up stuff. The downside of this is that the package isn't automatically rebuilt when the version changes (E.G. by a svn update) and you now also have to remove the stamp files next to $(BUILD_DIR)/<PACKAGE>-* to force a rebuild.
Diffstat (limited to 'package/pixman')
-rw-r--r--package/pixman/pixman.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/package/pixman/pixman.mk b/package/pixman/pixman.mk
index 0b20353bf..9270e6cef 100644
--- a/package/pixman/pixman.mk
+++ b/package/pixman/pixman.mk
@@ -13,38 +13,38 @@ $(eval $(call AUTOTARGETS,package,pixman))
# pixman for the host
PIXMAN_HOST_DIR:=$(BUILD_DIR)/pixman-$(PIXMAN_VERSION)-host
-PIXMAN_HOST_BINARY:=$(HOST_DIR)/usr/lib/libpixman-1.0.a
-$(PIXMAN_HOST_DIR)/.unpacked: $(DL_DIR)/$(PIXMAN_SOURCE)
- mkdir -p $(@D)
+$(STAMP_DIR)/host_pixman_unpacked: $(DL_DIR)/$(PIXMAN_SOURCE)
+ mkdir -p $(PIXMAN_HOST_DIR)
$(INFLATE$(suffix $(PIXMAN_SOURCE))) $< | \
- $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(PIXMAN_HOST_DIR) $(TAR_OPTIONS) -
touch $@
-$(PIXMAN_HOST_DIR)/.configured: $(PIXMAN_HOST_DIR)/.unpacked
- (cd $(@D); rm -rf config.cache; \
+$(STAMP_DIR)/host_pixman_configured: $(STAMP_DIR)/host_pixman_unpacked
+ (cd $(PIXMAN_HOST_DIR); rm -rf config.cache; \
$(HOST_CONFIGURE_OPTS) \
CFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)" \
- $(@D)/configure \
- --prefix=$(HOST_DIR)/usr \
- --sysconfdir=$(HOST_DIR)/etc \
+ ./configure \
+ --prefix="$(HOST_DIR)/usr" \
+ --sysconfdir="$(HOST_DIR)/etc" \
)
touch $@
-$(PIXMAN_HOST_DIR)/.compiled: $(PIXMAN_HOST_DIR)/.configured
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+$(STAMP_DIR)/host_pixman_compiled: $(STAMP_DIR)/host_pixman_configured
+ $(HOST_MAKE_ENV) $(MAKE) -C $(PIXMAN_HOST_DIR)
touch $@
-$(PIXMAN_HOST_BINARY): $(PIXMAN_HOST_DIR)/.compiled
- $(HOST_MAKE_ENV) $(MAKE) -C $(<D) install
+$(STAMP_DIR)/host_pixman_installed: $(STAMP_DIR)/host_pixman_compiled
+ $(HOST_MAKE_ENV) $(MAKE) -C $(PIXMAN_HOST_DIR) install
+ touch $@
-host-pixman: $(PIXMAN_HOST_BINARY)
+host-pixman: $(STAMP_DIR)/host_pixman_installed
host-pixman-source: pixman-source
host-pixman-clean:
- rm -f $(addprefix $(PIXMAN_HOST_DIR)/,.unpacked .configured .compiled)
+ rm -f $(addprefix $(STAMP_DIR)/host_pixman_,unpacked configured compiled installed)
-$(MAKE) -C $(PIXMAN_HOST_DIR) uninstall
-$(MAKE) -C $(PIXMAN_HOST_DIR) clean