summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 10:11:18 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 10:11:18 +0000
commite1c81b632752f1158191388714ab30f2994a56dc (patch)
tree26a5618473a4406529faf7464a342d54c29e8eb9 /package/php
parent514cdef23fb77f10752039c1a21aab20f0575930 (diff)
downloadbuildroot-novena-e1c81b632752f1158191388714ab30f2994a56dc.tar.gz
buildroot-novena-e1c81b632752f1158191388714ab30f2994a56dc.zip
- fix unpacking the tarballs, minor cleanups while at it.
Diffstat (limited to 'package/php')
-rw-r--r--package/php/php.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index df4317f68..2912fcbcf 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -7,7 +7,7 @@ PHP_VER:=5.2.3
PHP_SOURCE:=php-$(PHP_VER).tar.bz2
PHP_SITE:=http://us.php.net/get/${PHP_SOURCE}/from/us2.php.net/mirror
PHP_DIR:=$(BUILD_DIR)/php-$(PHP_VER)
-PHP_CAT=bzcat
+PHP_CAT=$(BZCAT)
PHP_DEPS=
PHP_TARGET_DEPS=
@@ -55,7 +55,7 @@ php-source: $(DL_DIR)/$(PHP_SOURCE)
$(PHP_DIR)/.unpacked: $(DL_DIR)/$(PHP_SOURCE)
$(PHP_CAT) $(DL_DIR)/$(PHP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $(PHP_DIR)/.unpacked
+ touch $@
$(PHP_DIR)/.configured: $(PHP_DIR)/.unpacked
(cd $(PHP_DIR); rm -rf config.cache; \
@@ -92,15 +92,15 @@ $(PHP_DIR)/.configured: $(PHP_DIR)/.unpacked
$(PHP_CGI) \
$(PHP_ZLIB) \
)
- touch $(PHP_DIR)/.configured
+ touch $@
$(PHP_DIR)/.built: $(PHP_DIR)/.configured
$(MAKE) CC=$(TARGET_CC) -C $(PHP_DIR)
- touch $(PHP_DIR)/.built
+ touch $@
$(PHP_DIR)/.staged: $(PHP_DIR)/.built
$(MAKE) DESTDIR=$(STAGING_DIR) INSTALL_ROOT=$(STAGING_DIR) CC=$(TARGET_CC) -C $(PHP_DIR) install
- touch $(PHP_DIR)/.staged
+ touch $@
$(TARGET_DIR)/usr/bin/php: $(PHP_DIR)/.staged
cp -dpf $(STAGING_DIR)/usr/bin/php $(TARGET_DIR)/usr/bin/php
@@ -113,7 +113,7 @@ $(TARGET_DIR)/usr/bin/php-cgi: $(PHP_DIR)/.staged
$(STRIP) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/bin/php-cgi
$(TARGET_DIR)/etc/php.ini: $(PHP_DIR)/.staged
- cp $(PHP_DIR)/php.ini-dist $(TARGET_DIR)/etc/php.ini
+ cp -f $(PHP_DIR)/php.ini-dist $(TARGET_DIR)/etc/php.ini
php: uclibc $(PHP_DEPS) $(PHP_TARGET_DEPS) $(TARGET_DIR)/etc/php.ini