summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 17:21:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:24:59 +0200
commitc692a3e44348b70153210733bd7d0c82028f8973 (patch)
tree7353e9385b4d38613ebecb1195bef419017648a0 /package/php
parente8ba6a5119ce025c351380a942f3a399d78fb9a7 (diff)
downloadbuildroot-novena-c692a3e44348b70153210733bd7d0c82028f8973.tar.gz
buildroot-novena-c692a3e44348b70153210733bd7d0c82028f8973.zip
php: convert old-style hooks to new-style hooks
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/php')
-rw-r--r--package/php/php.mk17
1 files changed, 10 insertions, 7 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index 9396311ef..68b0b5fc9 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -166,23 +166,26 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),y)
endif
endif
-$(eval $(call AUTOTARGETS,package,php))
-
-$(PHP_HOOK_POST_INSTALL):
+define PHP_INSTALL_FIXUP
rm -rf $(TARGET_DIR)/usr/lib/php
rm -f $(TARGET_DIR)/usr/bin/phpize
rm -f $(TARGET_DIR)/usr/bin/php-config
if [ ! -f $(TARGET_DIR)/etc/php.ini ]; then \
$(INSTALL) -m 0755 $(BR2_PACKAGE_PHP_CONFIG) $(TARGET_DIR)/etc/php.ini; fi
- touch $@
+endef
+
+PHP_POST_INSTALL_TARGET_HOOKS += PHP_INSTALL_FIXUP
-$(PHP_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define PHP_UNINSTALL_STAGING_CMDS
rm -rf $(STAGING_DIR)/usr/include/php
rm -rf $(STAGING_DIR)/usr/lib/php
rm -f $(STAGING_DIR)/usr/bin/php*
rm -f $(STAGING_DIR)/usr/share/man/man1/php*.1
+endef
+
+define PHP_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/etc/php.ini
rm -f $(TARGET_DIR)/usr/bin/php*
- rm -f $(PHP_TARGET_INSTALL_TARGET) $(PHP_HOOK_POST_INSTALL)
+endef
+$(eval $(call AUTOTARGETS,package,php))