summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-02-07 12:35:05 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-08 22:34:26 +0100
commita5ce8576748421b6dece97a665e575d7dfc9fbe8 (patch)
treed872f865298312833109804f95d5355fc919efc7 /package/php
parent580225af20b6c692da76eb43b20382a47b3ed170 (diff)
downloadbuildroot-novena-a5ce8576748421b6dece97a665e575d7dfc9fbe8.tar.gz
buildroot-novena-a5ce8576748421b6dece97a665e575d7dfc9fbe8.zip
package: use <pkg>_CONFIG_SCRIPTS wherever possible
Use the <pkg>_CONFIG_SCRIPTS mechanism in all packages for which it does all what the package was doing. A few packages, like libxslt, are for now left out, since they need some additional fixup (for example a fixup of includedir). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/php')
-rw-r--r--package/php/php.mk11
1 files changed, 1 insertions, 10 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index a1badabd2..c89b4674c 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -19,6 +19,7 @@ PHP_CONF_OPT = --mandir=/usr/share/man \
--with-config-file-path=/etc \
--localstatedir=/var \
--disable-rpath
+PHP_CONFIG_SCRIPTS = php-config
PHP_CFLAGS = $(TARGET_CFLAGS)
@@ -200,19 +201,9 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_SNMP),y)
PHP_DEPENDENCIES += netsnmp
endif
-# Fixup prefix= and exec_prefix= in php-config
-define PHP_FIXUP_PHP_CONFIG
- $(SED) 's%^prefix="/usr"%prefix="$(STAGING_DIR)/usr"%' \
- -e 's%^exec_prefix="/usr"%exec_prefix="$(STAGING_DIR)/usr"%' \
- $(STAGING_DIR)/usr/bin/php-config
-endef
-
-PHP_POST_INSTALL_STAGING_HOOKS += PHP_FIXUP_PHP_CONFIG
-
define PHP_INSTALL_FIXUP
rm -rf $(TARGET_DIR)/usr/lib/php
rm -f $(TARGET_DIR)/usr/bin/phpize
- rm -f $(TARGET_DIR)/usr/bin/php-config
if [ ! -f $(TARGET_DIR)/etc/php.ini ]; then \
$(INSTALL) -m 0755 $(PHP_DIR)/php.ini-production \
$(TARGET_DIR)/etc/php.ini; \