summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorThomas Rudin <thomas@rudin.li>2010-11-15 17:12:49 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-24 23:12:54 +0100
commit972cd4229b21f03183fe7b72a36ffc2be81d87e3 (patch)
tree1110397a4973735a3aaaea91c47ac4e5fb0fdcc7 /package/php
parenta7537caaac3354272bd4c83ee97cc3ec55ce7d60 (diff)
downloadbuildroot-novena-972cd4229b21f03183fe7b72a36ffc2be81d87e3.tar.gz
buildroot-novena-972cd4229b21f03183fe7b72a36ffc2be81d87e3.zip
php: add process control support
Closes #2791 Signed-off-by: Thomas Rudin <thomas@rudin.li> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/php')
-rw-r--r--package/php/Config.ext5
-rw-r--r--package/php/php.mk4
2 files changed, 9 insertions, 0 deletions
diff --git a/package/php/Config.ext b/package/php/Config.ext
index 0433abcfa..5c7f5ea68 100644
--- a/package/php/Config.ext
+++ b/package/php/Config.ext
@@ -103,6 +103,11 @@ config BR2_PACKAGE_PHP_EXT_PCRE
help
Perl Compatible Regular Expressions support
+config BR2_PACKAGE_PHP_EXT_PCNTL
+ bool "PCNTL"
+ help
+ Process Control Support
+
config BR2_PACKAGE_PHP_EXT_SYSVMSG
bool "sysvmsg - System V Message queue"
help
diff --git a/package/php/php.mk b/package/php/php.mk
index 68b0b5fc9..af4fa292a 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -106,6 +106,10 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_NCURSES),y)
PHP_DEPENDENCIES += ncurses
endif
+ifeq ($(BR2_PACKAGE_PHP_EXT_PCNTL),y)
+ PHP_CONF_OPT += --enable-pcntl
+endif
+
ifeq ($(BR2_PACKAGE_PHP_EXT_SYSVMSG),y)
PHP_CONF_OPT += --enable-sysvmsg
endif