summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-05-01 10:51:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-01 10:51:57 +0200
commit9374f6c1255b368b9ff3bd596408dbb35640d5d7 (patch)
treeafe3f9edcef2fd8b0319d46980f0aef94582ff66 /package/php
parentf64a1b850fc897357040bb4c58b6e5e50e71e094 (diff)
downloadbuildroot-novena-9374f6c1255b368b9ff3bd596408dbb35640d5d7.tar.gz
buildroot-novena-9374f6c1255b368b9ff3bd596408dbb35640d5d7.zip
php: fixup paths in php-config for cross compilation
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/php')
-rw-r--r--package/php/php.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index 7f848b178..6de6a9e83 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -171,6 +171,15 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),y)
endif
endif
+# Fixup prefix= and exec_prefix= in php-config
+define PHP_FIXUP_PHP_CONFIG
+ $(SED) 's%^prefix="/usr"%prefix="$(STAGING_DIR)/usr"%' \
+ -e 's%^exec_prefix="/usr"%exec_prefix="$(STAGING_DIR)/usr"%' \
+ $(STAGING_DIR)/usr/bin/php-config
+endef
+
+PHP_POST_INSTALL_STAGING_HOOKS += PHP_FIXUP_PHP_CONFIG
+
define PHP_INSTALL_FIXUP
rm -rf $(TARGET_DIR)/usr/lib/php
rm -f $(TARGET_DIR)/usr/bin/phpize