summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-06-02 05:32:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-05 08:53:19 +0200
commit12d80fcf93bbde9e2d929fe04d9a6e7b739d54c4 (patch)
treef130a418a87c1e4e695c34da0a18f826fc8427f5 /package/php
parent74da2cca30852cc12c5f6e83be39e301aff74d62 (diff)
downloadbuildroot-novena-12d80fcf93bbde9e2d929fe04d9a6e7b739d54c4.tar.gz
buildroot-novena-12d80fcf93bbde9e2d929fe04d9a6e7b739d54c4.zip
php: fix WDDX extension build failure
Fix WDDX extension build failure. The documentation and source are conflicting about this, in theory libexpat support is deprecated and libxml2 can replace it, but it seems not so for WDDX, so pull in expat for it. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/php')
-rw-r--r--package/php/Config.ext1
-rw-r--r--package/php/php.mk6
2 files changed, 6 insertions, 1 deletions
diff --git a/package/php/Config.ext b/package/php/Config.ext
index 80bab70da..2cf71d362 100644
--- a/package/php/Config.ext
+++ b/package/php/Config.ext
@@ -310,6 +310,7 @@ config BR2_PACKAGE_PHP_EXT_SIMPLEXML
config BR2_PACKAGE_PHP_EXT_WDDX
bool "WDDX"
+ select BR2_PACKAGE_EXPAT
select BR2_PACKAGE_PHP_EXT_LIBXML2
help
WDDX support
diff --git a/package/php/php.mk b/package/php/php.mk
index e9bda447f..af041c963 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -38,7 +38,6 @@ PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_EXT_SOCKETS),--enable-sockets) \
$(if $(BR2_PACKAGE_PHP_EXT_DOM),--enable-dom) \
$(if $(BR2_PACKAGE_PHP_EXT_SIMPLEXML),--enable-simplexml) \
$(if $(BR2_PACKAGE_PHP_EXT_SOAP),--enable-soap) \
- $(if $(BR2_PACKAGE_PHP_EXT_WDDX),--enable-wddx) \
$(if $(BR2_PACKAGE_PHP_EXT_XML),--enable-xml) \
$(if $(BR2_PACKAGE_PHP_EXT_XMLREADER),--enable-xmlreader) \
$(if $(BR2_PACKAGE_PHP_EXT_XMLWRITER),--enable-xmlwriter) \
@@ -68,6 +67,11 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_LIBXML2),y)
PHP_DEPENDENCIES += libxml2
endif
+ifeq ($(BR2_PACKAGE_PHP_EXT_WDDX),y)
+ PHP_CONF_OPT += --enable-wddx --with-libexpat-dir=$(STAGING_DIR)/usr
+ PHP_DEPENDENCIES += expat
+endif
+
ifeq ($(BR2_PACKAGE_PHP_EXT_XMLRPC),y)
PHP_CONF_OPT += --with-xmlrpc \
$(if $(BR2_PACKAGE_LIBICONV),--with-iconv-dir=$(STAGING_DIR)/usr)