summaryrefslogtreecommitdiffstats
path: root/package/perl
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2012-10-19 03:13:48 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-03 11:41:29 +0100
commitdf9a5973e9ff5c659e0901ef4b1e07f820ff149a (patch)
tree215010ebc52a69809071a2636de68d7365f21a93 /package/perl
parent4bb3d3bd1c38ecae81a403e1b741ad3cf96db16e (diff)
downloadbuildroot-novena-df9a5973e9ff5c659e0901ef4b1e07f820ff149a.tar.gz
buildroot-novena-df9a5973e9ff5c659e0901ef4b1e07f820ff149a.zip
perl: add DB_File
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/Config.in10
-rw-r--r--package/perl/perl.mk4
2 files changed, 14 insertions, 0 deletions
diff --git a/package/perl/Config.in b/package/perl/Config.in
index 0a41a97c3..6cb89f029 100644
--- a/package/perl/Config.in
+++ b/package/perl/Config.in
@@ -14,5 +14,15 @@ config BR2_PACKAGE_PERL
http://www.perl.org/
+if BR2_PACKAGE_PERL
+
+config BR2_PACKAGE_PERL_DB_FILE
+ bool "DB_File"
+ select BR2_PACKAGE_BERKELEYDB
+ help
+ Build the DB_File module.
+
+endif
+
comment "perl requires an architecture supported by qemu"
depends on BR2_avr32 || BR2_bfin || BR2_sh2 || BR2_sh2a || BR2_sh3 || BR2_sh3eb || BR2_sh64
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 7ac1aed87..186158bf2 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -11,7 +11,11 @@ PERL_SOURCE = perl-$(PERL_VERSION).tar.bz2
PERL_LICENSE = Artistic
PERL_LICENSE_FILES = Artistic
PERL_INSTALL_STAGING = YES
+
PERL_DEPENDENCIES = host-qemu
+ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
+ PERL_DEPENDENCIES += berkeleydb
+endif
PERL_CONF_OPT = -des \
-Dusecrosscompile \