summaryrefslogtreecommitdiffstats
path: root/package/perl
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2012-10-19 03:13:50 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-03 11:52:57 +0100
commit1ff20d33e3f213ea1efc2e6939516b1ea43393c4 (patch)
tree43875f53d47f9b4126c91ca9c5afe35b340c7c5a /package/perl
parente0cf9e86b92a831adfadb97baa3919039a3e5669 (diff)
downloadbuildroot-novena-1ff20d33e3f213ea1efc2e6939516b1ea43393c4.tar.gz
buildroot-novena-1ff20d33e3f213ea1efc2e6939516b1ea43393c4.zip
perl: add GDBM_File
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/Config.in6
-rw-r--r--package/perl/perl.mk3
2 files changed, 9 insertions, 0 deletions
diff --git a/package/perl/Config.in b/package/perl/Config.in
index 6cb89f029..98b41da4f 100644
--- a/package/perl/Config.in
+++ b/package/perl/Config.in
@@ -22,6 +22,12 @@ config BR2_PACKAGE_PERL_DB_FILE
help
Build the DB_File module.
+config BR2_PACKAGE_PERL_GDBM_FILE
+ bool "GDBM_File"
+ select BR2_PACKAGE_GDBM
+ help
+ Build the GDBM_File module.
+
endif
comment "perl requires an architecture supported by qemu"
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 186158bf2..56abbc1f1 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -16,6 +16,9 @@ PERL_DEPENDENCIES = host-qemu
ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
PERL_DEPENDENCIES += berkeleydb
endif
+ifeq ($(BR2_PACKAGE_GDBM),y)
+ PERL_DEPENDENCIES += gdbm
+endif
PERL_CONF_OPT = -des \
-Dusecrosscompile \