summaryrefslogtreecommitdiffstats
path: root/package/perl
diff options
context:
space:
mode:
authorShawn J. Goff <shawn7400@gmail.com>2013-04-12 09:40:30 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-15 20:33:52 +0200
commit1cbffbd015106ea90fe49e27433375769dc1035b (patch)
tree9868e930e6ad567dcbc62f2247511da39357d084 /package/perl
parentc24e66a3ee4d8933d21fe0e6207a6a9aec12ba81 (diff)
downloadbuildroot-novena-1cbffbd015106ea90fe49e27433375769dc1035b.tar.gz
buildroot-novena-1cbffbd015106ea90fe49e27433375769dc1035b.zip
eliminate double slashes caused by FOO_SITE ending in a slash
When a FOO_SITE variable ends in a slash and gets joined with a FOO_SOURCE variable like $(FOO_SITE)/$(FOO_SOURCE), the resulting URI has a double slash. While double-slashes are fine in unix paths, they are reserved in URIs - the part following '//' must be an authority. Signed-off-by: Shawn J. Goff <shawn7400@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/perl.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 66f7daac9..42512f8d0 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -25,7 +25,7 @@ PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
# together with perl
define PERL_CROSS_DOWNLOAD
- $(call DOWNLOAD,$(PERL_CROSS_SITE)/$(PERL_CROSS_SOURCE))
+ $(call DOWNLOAD,$(PERL_CROSS_SITE:/=)/$(PERL_CROSS_SOURCE))
endef
PERL_POST_DOWNLOAD_HOOKS += PERL_CROSS_DOWNLOAD