summaryrefslogtreecommitdiffstats
path: root/package/perf
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-06 05:22:46 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-07 21:39:55 +0100
commit69030ca5c9324a36ecaf55aa3b23bfa5443b2c8f (patch)
tree4e63d813a548c5e41ed3e540d1d2775f5cf4f6c2 /package/perf
parentd82f5cb94a163774eb9e0c689d246e2a7e15ca62 (diff)
downloadbuildroot-novena-69030ca5c9324a36ecaf55aa3b23bfa5443b2c8f.tar.gz
buildroot-novena-69030ca5c9324a36ecaf55aa3b23bfa5443b2c8f.zip
perf: allow build against libelf when available
Now that libelf is available thanks to elfutils (for glibc only), allow to build perf against it if available. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/perf')
-rw-r--r--package/perf/perf.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/perf/perf.mk b/package/perf/perf.mk
index 2aef9005b..eed30a289 100644
--- a/package/perf/perf.mk
+++ b/package/perf/perf.mk
@@ -12,8 +12,6 @@ PERF_DEPENDENCIES = linux
PERF_MAKE_FLAGS = \
$(LINUX_MAKE_FLAGS) \
- NO_LIBELF=1 \
- NO_DWARF=1 \
NO_LIBAUDIT=1 \
NO_NEWT=1 \
NO_GTK2=1 \
@@ -23,6 +21,12 @@ PERF_MAKE_FLAGS = \
prefix=/usr \
WERROR=0
+ifeq ($(BR2_PACKAGE_ELFUTILS),y)
+ PERF_DEPENDENCIES += elfutils
+else
+ PERF_MAKE_FLAGS += NO_LIBELF=1 NO_DWARF=1
+endif
+
define PERF_BUILD_CMDS
$(MAKE) -C $(LINUX_DIR)/tools/perf \
$(PERF_MAKE_FLAGS) O=$(@D)