summaryrefslogtreecommitdiffstats
path: root/package/pcre
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-08-16 12:32:54 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-08-16 12:32:54 +0000
commit9b28d48012c33b37d33101991fa042f9fc9d76eb (patch)
tree9a9e1a36475f30a0ad84969c097d98d310fecbaf /package/pcre
parent844f1013dca2bb352325a1abbdfce98d6d69f892 (diff)
downloadbuildroot-novena-9b28d48012c33b37d33101991fa042f9fc9d76eb.tar.gz
buildroot-novena-9b28d48012c33b37d33101991fa042f9fc9d76eb.zip
pcre: fix compilation when C++ support is disabled
pcre will use host g++ is no cross g++ is available, so explicitly disable c++ support in pcre if it isn't enabled in buildroot instead.
Diffstat (limited to 'package/pcre')
-rw-r--r--package/pcre/pcre.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/pcre/pcre.mk b/package/pcre/pcre.mk
index f6f7003d0..367f36cf1 100644
--- a/package/pcre/pcre.mk
+++ b/package/pcre/pcre.mk
@@ -9,9 +9,10 @@ PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
PCRE_INSTALL_STAGING = YES
PCRE_INSTALL_TARGET = YES
-PCRE_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) --prefix=/usr \
- --includedir=/usr/include
+ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
+# pcre will use the host g++ if a cross version isn't available
+PCRE_CONF_OPT = --disable-cpp
+endif
PCRE_DEPENDENCIES = uclibc