summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-05-06 11:24:36 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-06 23:07:21 +0200
commita5fe7371b28ed52a019dc424821f199d0f86b969 (patch)
treec76ee4e582172cefeebdf6e705eaacb90c004341 /package/pciutils
parentdfb503937df53cb1e43a33f264b561bc99acf6ff (diff)
downloadbuildroot-novena-a5fe7371b28ed52a019dc424821f199d0f86b969.tar.gz
buildroot-novena-a5fe7371b28ed52a019dc424821f199d0f86b969.zip
pciutils: Fix cross compiling
Closes #1705 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/Config.in3
-rw-r--r--package/pciutils/pciutils.mk4
2 files changed, 7 insertions, 0 deletions
diff --git a/package/pciutils/Config.in b/package/pciutils/Config.in
index bc026602f..07fc49b82 100644
--- a/package/pciutils/Config.in
+++ b/package/pciutils/Config.in
@@ -7,4 +7,7 @@ config BR2_PACKAGE_PCIUTILS
Various utilities dealing with the PCI bus.
Provides things like setpci and lspci.
+ You'll need a copy of pci.ids or pci.ids.gz in your
+ target skeleton to enjoy verbose output.
+
http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 393162f62..2b999dfb5 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -18,10 +18,12 @@ define PCIUTILS_CONFIGURE_CMDS
$(SED) 's/uname -s/echo Linux/' \
-e 's/uname -r/echo $(LINUX_HEADERS_VERSION)/' \
$(PCIUTILS_DIR)/lib/configure
+ $(SED) 's/^STRIP/#STRIP/' $(PCIUTILS_DIR)/Makefile
endef
define PCIUTILS_BUILD_CMDS
$(MAKE) CC="$(TARGET_CC)" \
+ HOST="$(KERNEL_ARCH)-linux" \
OPT="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
RANLIB=$(TARGET_RANLIB) \
@@ -33,8 +35,10 @@ define PCIUTILS_BUILD_CMDS
SHAREDIR=/usr/share/misc
endef
+# Ditch install-lib if SHARED is an option in the future
define PCIUTILS_INSTALL_TARGET_CMDS
$(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install
+ $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install-lib
endef
$(eval $(call GENTARGETS,package,pciutils))