summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /package/pciutils
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
downloadbuildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.tar.gz
buildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.zip
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/pciutils.mk52
1 files changed, 52 insertions, 0 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
new file mode 100644
index 000000000..219864f74
--- /dev/null
+++ b/package/pciutils/pciutils.mk
@@ -0,0 +1,52 @@
+#############################################################
+#
+# pciutils
+#
+#############################################################
+PCIUTILS_VER:=2.1.11
+PCIUTILS_SOURCE:=pciutils-$(PCIUTILS_VER).tar.gz
+PCIUTILS_SITE:=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+PCIUTILS_DIR:=$(BUILD_DIR)/pciutils-$(PCIUTILS_VER)
+PCIUTILS_CAT:=zcat
+
+# Yet more targets...
+PCIIDS_SITE:=http://pciids.sourceforge.net/
+PCIIDS_SOURCE:=pci.ids.bz2
+PCIIDS_CAT:=bzcat
+
+$(DL_DIR)/$(PCIUTILS_SOURCE):
+ $(WGET) -P $(DL_DIR) $(PCIUTILS_SITE)/$(PCIUTILS_SOURCE)
+
+$(DL_DIR)/$(PCIIDS_SOURCE):
+ $(WGET) -P $(DL_DIR) $(PCIIDS_SITE)/$(PCIIDS_SOURCE)
+
+pciutils-source: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
+
+$(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
+ $(PCIUTILS_CAT) $(DL_DIR)/$(PCIUTILS_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ $(PCIIDS_CAT) $(DL_DIR)/$(PCIIDS_SOURCE) > $(PCIUTILS_DIR)/pci.id
+ $(SOURCE_DIR)/patch-kernel.sh $(PCIUTILS_DIR) $(SOURCE_DIR) pciutils*.patch
+ touch $(PCIUTILS_DIR)/.unpacked
+
+$(PCIUTILS_DIR)/.compiled: $(PCIUTILS_DIR)/.unpacked
+ $(MAKE) CC=$(TARGET_CC) OPT="$(TARGET_CFLAGS)" -C $(PCIUTILS_DIR)
+ touch $(PCIUTILS_DIR)/.compiled
+
+$(TARGET_DIR)/sbin/lspci: $(PCIUTILS_DIR)/.compiled
+ install -c $(PCIUTILS_DIR)/lspci $(TARGET_DIR)/sbin/lspci
+
+$(TARGET_DIR)/sbin/setpci: $(PCIUTILS_DIR)/.compiled
+ install -c $(PCIUTILS_DIR)/setpci $(TARGET_DIR)/sbin/setpci
+
+$(TARGET_DIR)/usr/share/misc/pci.ids: $(PCIUTILS_DIR)/.compiled
+ install -Dc $(PCIUTILS_DIR)/pci.ids $(TARGET_DIR)/usr/share/misc/pci.ids
+
+pciutils: uclibc $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/usr/share/misc/pci.ids
+
+pciutils-clean:
+ rm $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/usr/share/misc/pci.ids
+ -$(MAKE) -C $(PCIUTILS_DIR) clean
+
+pciutils-dirclean:
+ rm -rf $(PCIUTILS_DIR)
+