summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-05 12:57:41 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-05 12:57:41 +0000
commit630bbb9a8514e2186f9e5326accdab38aec4e42a (patch)
tree8a0ad7cd0812c0e6cb6784207a9bf76341c6199e /package/pciutils
parenta353f4ab3dc1be43f9121eed98149d006fd13d70 (diff)
downloadbuildroot-novena-630bbb9a8514e2186f9e5326accdab38aec4e42a.tar.gz
buildroot-novena-630bbb9a8514e2186f9e5326accdab38aec4e42a.zip
- set PREFIX and SHAREDIR proper
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/pciutils.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 52004df6b..032207804 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -29,7 +29,9 @@ $(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURC
touch $(PCIUTILS_DIR)/.unpacked
$(PCIUTILS_DIR)/.compiled: $(PCIUTILS_DIR)/.unpacked
- $(MAKE1) CC=$(TARGET_CC) OPT="$(TARGET_CFLAGS)" -C $(PCIUTILS_DIR)
+ $(MAKE1) CC=$(TARGET_CC) OPT="$(TARGET_CFLAGS)" -C $(PCIUTILS_DIR) \
+ SHAREDIR="/usr/share/misc" \
+ PREFIX=/usr
touch $(PCIUTILS_DIR)/.compiled
$(TARGET_DIR)/sbin/lspci: $(PCIUTILS_DIR)/.compiled
@@ -38,7 +40,7 @@ $(TARGET_DIR)/sbin/lspci: $(PCIUTILS_DIR)/.compiled
$(TARGET_DIR)/sbin/setpci: $(PCIUTILS_DIR)/.compiled
install -c $(PCIUTILS_DIR)/setpci $(TARGET_DIR)/sbin/setpci
-$(TARGET_DIR)/usr/share/misc/pci.ids: $(PCIUTILS_DIR)/.compiled
+$(TARGET_DIR)/usr/share/misc/pci.ids: $(PCIUTILS_DIR)/.unpacked
install -Dc $(PCIUTILS_DIR)/pci.ids $(TARGET_DIR)/usr/share/misc/pci.ids
pciutils: uclibc $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/usr/share/misc/pci.ids