summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-01-10 10:47:23 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-10 14:52:02 +0100
commit54942318f93b12f8166f110905ec7df6e3279a74 (patch)
tree116081d50b734a92ecb88d8259b4dca66197b910 /package/pciutils
parentc7333781cc192839c4ec78d262f3e4604cd79948 (diff)
downloadbuildroot-novena-54942318f93b12f8166f110905ec7df6e3279a74.tar.gz
buildroot-novena-54942318f93b12f8166f110905ec7df6e3279a74.zip
pciutils: SHARED make opt goes for install too
If we don't pass SHARED when installing we miss the shared library symlinks (libpci.so & libpci.so.3). On internal and external toolchains that have a proper cross ldconfig this isn't a problem as they get created during ldconfig, but it breaks on toolchains that lack a cross ldconfig to automagically make the symlinks. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/pciutils.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 6e163006b..782d348ea 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -39,8 +39,10 @@ endef
# Ditch install-lib if SHARED is an option in the future
define PCIUTILS_INSTALL_TARGET_CMDS
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install-lib
+ $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
+ SHARED=$(PCIUTILS_SHARED) install
+ $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
+ SHARED=$(PCIUTILS_SHARED) install-lib
endef
$(eval $(call GENTARGETS,package,pciutils))