summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorNigel Kukard <nkukard@lbsd.net>2009-01-02 12:01:49 +0000
committerNigel Kukard <nkukard@lbsd.net>2009-01-02 12:01:49 +0000
commit380d77c6a36811044098ea013e77c11a87df1b32 (patch)
treec2d11b227ab3c7774a7884f4815d0f1ef3177c21 /package/pciutils
parentabda4017111c0f81149ca627857d34742dd506cc (diff)
downloadbuildroot-novena-380d77c6a36811044098ea013e77c11a87df1b32.tar.gz
buildroot-novena-380d77c6a36811044098ea013e77c11a87df1b32.zip
* Fix format of the pciutils pci.ids.gz data file
- If ZLIB is present the filename of pci.ids is changed to pci.ids.gz but its not compressed, add a compressor to ensure its gzipped
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/pciutils.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index f9cc6bc86..8d2ad67ae 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -17,9 +17,11 @@ PCIIDS_CAT:=$(BZCAT)
ifeq ($(BR2_PACKAGE_ZLIB),y)
PCIUTILS_HAVE_ZLIB=yes
PCIIDS_FILE=pci.ids.gz
+PCIIDS_COMPRESSOR=gzip -9 -c
else
PCIUTILS_HAVE_ZLIB=no
PCIIDS_FILE=pci.ids
+PCIIDS_COMPRESSOR=cat
endif
$(DL_DIR)/$(PCIUTILS_SOURCE):
@@ -30,7 +32,7 @@ $(DL_DIR)/$(PCIIDS_SOURCE):
$(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
$(PCIUTILS_CAT) $(DL_DIR)/$(PCIUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- $(PCIIDS_CAT) $(DL_DIR)/$(PCIIDS_SOURCE) > $(PCIUTILS_DIR)/$(PCIIDS_FILE)
+ $(PCIIDS_CAT) $(DL_DIR)/$(PCIIDS_SOURCE) | $(PCIIDS_COMPRESSOR) > $(PCIUTILS_DIR)/$(PCIIDS_FILE)
toolchain/patch-kernel.sh $(PCIUTILS_DIR) package/pciutils pciutils-$(PCIUTILS_VERSION)\*.patch
#$(CONFIG_UPDATE) $(@D)
$(SED) 's/uname -s/echo Linux/' \