summaryrefslogtreecommitdiffstats
path: root/package/pciutils
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-24 08:22:26 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-24 08:22:26 +0200
commit096b21e552b05b68a846172e320ae3e38dee16ac (patch)
tree2a2f0ee9b0bd66e3cb52ee1c4e72c9fac5035fd7 /package/pciutils
parent78cff154eaf2e240464d24964ea1a92fa9b68297 (diff)
downloadbuildroot-novena-096b21e552b05b68a846172e320ae3e38dee16ac.tar.gz
buildroot-novena-096b21e552b05b68a846172e320ae3e38dee16ac.zip
pciutils: fix access to pci.ids and make update-pciids work with busybox wget
Closes #1819 Fix two issues with pciutils: - pciutils would look in /usr/share/misc for pci.ids, but install it in /usr/share. This is because pciutils doesn't use a ./configure script, so we have to also provide the configuration (make) arguments when we run make install as well. Fix it by making it look into /usr/share as that's simpler to do, and is what upstream does. - the update-pciids script would call wget with the --no-timestamping option, which isn't supported by busybox wget. Fix it by simply removing that option as it isn't really critical. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pciutils')
-rw-r--r--package/pciutils/pciutils.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 2b999dfb5..a7d999664 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -15,6 +15,7 @@ PCIUTILS_DNS=no
PCIUTILS_SHARED=yes
define PCIUTILS_CONFIGURE_CMDS
+ $(SED) 's/wget --no-timestamping/wget/' $(PCIUTILS_DIR)/update-pciids.sh
$(SED) 's/uname -s/echo Linux/' \
-e 's/uname -r/echo $(LINUX_HEADERS_VERSION)/' \
$(PCIUTILS_DIR)/lib/configure
@@ -32,7 +33,7 @@ define PCIUTILS_BUILD_CMDS
SHARED=$(PCIUTILS_SHARED) \
ZLIB=$(PCIUTILS_ZLIB) \
DNS=$(PCIUTILS_DNS) \
- SHAREDIR=/usr/share/misc
+ PREFIX=/usr
endef
# Ditch install-lib if SHARED is an option in the future