summaryrefslogtreecommitdiffstats
path: root/package/pango
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-15 16:42:23 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-20 22:34:29 +0200
commit832ce382c6fbd416ac562da10ba3946e3fc7b935 (patch)
tree4205757ac7b9f6108e390f629ec243b09225ce1a /package/pango
parent0317b30912eb73bc512b137b1581ff520b14c40a (diff)
downloadbuildroot-novena-832ce382c6fbd416ac562da10ba3946e3fc7b935.tar.gz
buildroot-novena-832ce382c6fbd416ac562da10ba3946e3fc7b935.zip
pango: run pango-querymodules on the target instead of on the host
We needed to build pango for the host in order to compile pango-querymodules for the host, which was used to produce /etc/pango/pango.modules. Unfortunately: * This produces an incorrect /etc/pango/pango.modules (no modules detected in my case), probably because the host pango-querymodules was looking at host pango modules * This requires to build pango for the host, which requires to build cairo for the host, which requires to build X11 for the host. To make things work and remove the dependency between pango and host-pango, we introduce a S25pango script that creates /etc/pango/pango.modules on startup if it doesn't exist, just as we do with libgtk2 for /etc/gtk-2.0/gdk-pixbuf.loaders. Since host-pango is no longer needed, we remove all definitions related to it. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pango')
-rw-r--r--package/pango/S25pango20
-rw-r--r--package/pango/pango.mk18
2 files changed, 22 insertions, 16 deletions
diff --git a/package/pango/S25pango b/package/pango/S25pango
new file mode 100644
index 000000000..9af9307c4
--- /dev/null
+++ b/package/pango/S25pango
@@ -0,0 +1,20 @@
+#!/bin/sh
+#
+# run pango-querymodules if needed
+
+FILE=/etc/pango/pango.modules
+
+case "$1" in
+ start|"")
+ if [ ! -f $FILE ] ; then
+ mkdir -p /etc/pango
+ /usr/bin/pango-querymodules > "$FILE"
+ fi
+ ;;
+ stop)
+ ;;
+ *)
+ echo "Usage: $0 {start|stop}" >&2
+ exit 1
+ ;;
+esac \ No newline at end of file
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index 812a4c872..c64004584 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -40,16 +40,7 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
PANGO_CONF_OPT = --enable-shared --enable-static \
--enable-explicit-deps=no --disable-debug
-HOST_PANGO_CONF_OPT = \
- --disable-static \
- $(if $(BR2_PACKAGE_XORG7),--with-x,--without-x) \
- --disable-debug \
-
-PANGO_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT),gettext libintl) host-pkg-config host-pango libglib2 cairo
-
-HOST_PANGO_DEPENDENCIES = host-pkg-config host-cairo host-libglib2 host-autoconf host-automake
-
-HOST_PANGO_AUTORECONF = YES
+PANGO_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT),gettext libintl) host-pkg-config libglib2 cairo
ifeq ($(BR2_PACKAGE_XORG7),y)
PANGO_CONF_OPT += --with-x \
@@ -61,12 +52,7 @@ else
endif
$(eval $(call AUTOTARGETS,package,pango))
-$(eval $(call AUTOTARGETS,package,pango,host))
$(PANGO_HOOK_POST_INSTALL):
- mkdir -p $(TARGET_DIR)/etc/pango
- $(PANGO_HOST_BINARY) > $(TARGET_DIR)/etc/pango/pango.modules
- $(SED) 's~$(HOST_DIR)~~g' $(TARGET_DIR)/etc/pango/pango.modules
+ $(INSTALL) -m 755 package/pango/S25pango $(TARGET_DIR)/etc/init.d/
touch $@
-
-PANGO_HOST_BINARY:=$(HOST_DIR)/usr/bin/pango-querymodules