summaryrefslogtreecommitdiffstats
path: root/package/pango
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-17 16:26:29 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-24 23:26:48 +0200
commit74ecbaa23da486182a1bb20b43361aaf2a478877 (patch)
tree2b884fababa50877fd39f1dc127d81446ef0bf87 /package/pango
parentb36a5894809b71b65da3fcfa8ba4b2a645c01194 (diff)
downloadbuildroot-novena-74ecbaa23da486182a1bb20b43361aaf2a478877.tar.gz
buildroot-novena-74ecbaa23da486182a1bb20b43361aaf2a478877.zip
xorg: remove the XSERVER variable
The XSERVER variable used to be defined by package/Makefile.in because the X server package name was different depending on the type of X server that was choosen. Nowadays, the name of the package is always xserver_xorg-server, so there's no point in having this XSERVER intermediate variable. This patch makes all packages use xserver_xorg-server directly as a dependency, and removes the XSERVER variable from package/Makefile.in. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pango')
-rw-r--r--package/pango/pango.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index 8cccae65f..2bcebf3b7 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -40,20 +40,20 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
ac_use_included_regex=no gl_cv_c_restrict=no \
ac_cv_path_FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
+PANGO_CONF_OPT = --enable-shared --enable-static \
+ --enable-explicit-deps=no --disable-debug
+
+PANGO_DEPENDENCIES = uclibc gettext libintl host-pkgconfig libglib2 cairo
+
ifeq ($(BR2_PACKAGE_XORG7),y)
- PANGO_CONF_OPT_X = --with-x \
+ PANGO_CONF_OPT += --with-x \
--x-includes=$(STAGING_DIR)/usr/include/X11 \
--x-libraries=$(STAGING_DIR)/usr/lib --disable-glibtest
+ PANGO_DEPENDENCIES += xserver_xorg-server
else
- PANGO_CONF_OPT_X = --without-x
+ PANGO_CONF_OPT += --without-x
endif
-PANGO_CONF_OPT = --enable-shared --enable-static \
- $(PANGO_CONF_OPT_X) \
- --enable-explicit-deps=no --disable-debug
-
-PANGO_DEPENDENCIES = uclibc gettext libintl host-pkgconfig libglib2 $(XSERVER) cairo
-
$(eval $(call AUTOTARGETS,package,pango))
$(PANGO_HOOK_POST_INSTALL):