summaryrefslogtreecommitdiffstats
path: root/package/pango
diff options
context:
space:
mode:
authorWill Newton <will.newton@gmail.com>2009-08-25 13:03:33 +0100
committerWill Newton <will.newton@gmail.com>2009-09-20 19:34:27 +0100
commit51173980cdbc89832db17765209e0ccef5be5cf8 (patch)
treeefb373d34e97b65b19e2e1076cbd51d738d4335f /package/pango
parentbf5e693d75890f5642e1679af40a687b9189de9c (diff)
downloadbuildroot-novena-51173980cdbc89832db17765209e0ccef5be5cf8.tar.gz
buildroot-novena-51173980cdbc89832db17765209e0ccef5be5cf8.zip
package/Makefile.in: Use appropriate paths for host pkg-config.
PKG_CONFIG_PATH adds a path to the pkg-config search path, but this is not enough when we are building host tools - the host pkg-config default path is still used, and this will pick up .pc files in the staging_dir tree. PKG_CONFIG_LIBDIR overrides the pkg-config default path and ensures only host .pc files are found. This fixes a pango build failure when building for the host with cairo PNG support enabled. Signed-off-by: Will Newton <will.newton@gmail.com>
Diffstat (limited to 'package/pango')
-rw-r--r--package/pango/pango.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index b66baf212..21c219f62 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -91,7 +91,7 @@ $(STAMP_DIR)/host_pango_configured: $(STAMP_DIR)/host_pango_unpacked $(STAMP_DIR
touch $@
$(STAMP_DIR)/host_pango_compiled: $(STAMP_DIR)/host_pango_configured
- $(HOST_MAKE_ENV) PKG_CONFIG_PATH="$(HOST_DIR)/usr/lib/pkgconfig$(PKG_CONFIG_PATH)" $(MAKE) -C $(PANGO_HOST_DIR)
+ $(HOST_MAKE_ENV) $(MAKE) -C $(PANGO_HOST_DIR)
touch $@
$(STAMP_DIR)/host_pango_installed: $(STAMP_DIR)/host_pango_compiled