summaryrefslogtreecommitdiffstats
path: root/package/pango
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-10-20 13:57:30 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-10-20 13:57:30 +0000
commit00ad71901b92627d8b4dd65e0a2caa3613f92857 (patch)
treed463241f4f8449029ddbe0632f0386e3cacebaf8 /package/pango
parente337d002fe4f258897f9d7ac5292e243b88b4cfd (diff)
downloadbuildroot-novena-00ad71901b92627d8b4dd65e0a2caa3613f92857.tar.gz
buildroot-novena-00ad71901b92627d8b4dd65e0a2caa3613f92857.zip
package/pango/pango.mk: Remove redundant PKG_CONFIG_*
Remove the unnecessary PKG_CONFIG_* settings and tidy up some config options. Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
Diffstat (limited to 'package/pango')
-rw-r--r--package/pango/pango.mk15
1 files changed, 3 insertions, 12 deletions
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index 89f0e6337..c599fd5a8 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -39,7 +39,7 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
am_getline_needs_run_time_check=no am_cv_func_working_getline=yes \
gl_cv_func_mkdir_trailing_slash_bug=no gl_cv_func_mkstemp_limitations=no \
ac_cv_func_working_mktime=yes jm_cv_func_working_re_compile_pattern=yes \
- ac_use_included_regex=no gl_cv_c_restrict=no PKG_CONFIG_SYSROOT="$(STAGING_DIR)" \
+ ac_use_included_regex=no gl_cv_c_restrict=no)" \
ac_cv_path_GLIB_GENMARSHAL=$(HOST_GLIB)/bin/glib-genmarshal ac_cv_path_FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
ifneq ($(BR2_PACKAGE_XSERVER_none),y)
@@ -50,19 +50,10 @@ else
PANGO_CONF_OPT_X = --without-x
endif
-PANGO_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) --prefix=/usr --exec-prefix=/usr \
- --bindir=/usr/bin --sbindir=/usr/sbin \
- --libdir=/usr/lib --libexecdir=/usr/lib \
- --sysconfdir=/etc --datadir=/usr/share \
- --localstatedir=/var --includedir=/usr/include \
- --mandir=/usr/man --infodir=/usr/info \
- --enable-shared --enable-static \
+PANGO_CONF_OPT = --enable-shared --enable-static \
$(PANGO_CONF_OPT_X) \
- --enable-explicit-deps=no --disable-debug PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
-
+ --enable-explicit-deps=no --disable-debug
PANGO_DEPENDENCIES = uclibc gettext libintl pkgconfig libglib2 $(XSERVER) cairo
-
$(eval $(call AUTOTARGETS,package,pango))