summaryrefslogtreecommitdiffstats
path: root/package/oprofile
diff options
context:
space:
mode:
authorJeremy Rosen <jeremy.rosen@openwide.fr>2012-12-14 04:24:09 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-06 22:11:37 +0100
commitc8c40f7278ac680c0be4b54d1517699b627cf48b (patch)
tree517d696b6b083804f78acffdf253fc4fd49d5c65 /package/oprofile
parenta425c2a404066ab8cc5f7c5caef9a6a8bd0bfd1e (diff)
downloadbuildroot-novena-c8c40f7278ac680c0be4b54d1517699b627cf48b.tar.gz
buildroot-novena-c8c40f7278ac680c0be4b54d1517699b627cf48b.zip
oprofile: bump to version 0.9.8
Signed-off-by: Jérémy Rosen <jeremy.rosen@openwide.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/oprofile')
-rw-r--r--package/oprofile/oprofile.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index 75f84073b..f3ea23f92 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -4,13 +4,14 @@
#
#############################################################
-OPROFILE_VERSION = 0.9.7
+OPROFILE_VERSION = 0.9.8
OPROFILE_SITE = http://downloads.sourceforge.net/project/oprofile/oprofile/oprofile-$(OPROFILE_VERSION)
OPROFILE_LICENSE = GPLv2+
OPROFILE_LICENSE_FILES = COPYING
OPROFILE_CONF_OPT = --localstatedir=/var --with-kernel-support
OPROFILE_BINARIES = utils/ophelp pp/opannotate pp/oparchive pp/opgprof
OPROFILE_BINARIES += pp/opreport opjitconv/opjitconv daemon/oprofiled
+OPROFILE_BINARIES += utils/op-check-perfevents pe_profiling/operf libabi/opimport
ifeq ($(BR2_i386),y)
OPROFILE_ARCH = i386
@@ -33,6 +34,7 @@ OPROFILE_DEPENDENCIES = popt binutils
define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/share/oprofile
+ $(INSTALL) -d -m 755 $(TARGET_DIR)/usr/lib/oprofile
if [ -d $(@D)/events/$(OPROFILE_ARCH) ]; then \
cp -dpfr $(@D)/events/$(OPROFILE_ARCH) \
$(TARGET_DIR)/usr/share/oprofile; \
@@ -40,12 +42,14 @@ define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -m 644 $(@D)/libregex/stl.pat $(TARGET_DIR)/usr/share/oprofile
$(INSTALL) -m 755 $(@D)/utils/opcontrol $(TARGET_DIR)/usr/bin
$(INSTALL) -m 755 $(addprefix $(@D)/, $(OPROFILE_BINARIES)) $(TARGET_DIR)/usr/bin
+ $(INSTALL) -m 755 $(@D)/libopagent/.libs/*.so* $(TARGET_DIR)/usr/lib/oprofile
endef
define OPROFILE_UNINSTALL_TARGET_CMDS
rm -f $(addprefix $(TARGET_DIR)/usr/bin/, $(notdir $(OPROFILE_BINARIES)))
rm -f $(TARGET_DIR)/usr/bin/opcontrol
rm -rf $(TARGET_DIR)/usr/share/oprofile
+ rm -rf $(TARGET_DIR)/usr/lib/oprofile
endef
$(eval $(autotools-package))