summaryrefslogtreecommitdiffstats
path: root/package/oprofile
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-10-26 21:21:43 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-27 14:04:56 +0200
commit2a56a141e09b1540875abb572229e5eaec68aef8 (patch)
treee908a9459c051e55f1b531deab32cfaceffead85 /package/oprofile
parent48391acd2c63ea373f9771210b3acd54ec97fb00 (diff)
downloadbuildroot-novena-2a56a141e09b1540875abb572229e5eaec68aef8.tar.gz
buildroot-novena-2a56a141e09b1540875abb572229e5eaec68aef8.zip
oprofile: bump to version 0.9.7 and fixes
* Bump to version 0.9.7 * Style fixes * Build fix for x86: i386 is expected, not some other random i?86 as arch Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/oprofile')
-rw-r--r--package/oprofile/oprofile-0.9.7-001-avr32-enable-lookup_dcookie.patch (renamed from package/oprofile/oprofile-0.9.4-001-avr32-enable-lookup_dcookie.patch)0
-rw-r--r--package/oprofile/oprofile-0.9.7-002-no-query-modules.patch (renamed from package/oprofile/oprofile-0.9.4-002-no-query-modules.patch)0
-rw-r--r--package/oprofile/oprofile.mk21
3 files changed, 11 insertions, 10 deletions
diff --git a/package/oprofile/oprofile-0.9.4-001-avr32-enable-lookup_dcookie.patch b/package/oprofile/oprofile-0.9.7-001-avr32-enable-lookup_dcookie.patch
index 7c4138946..7c4138946 100644
--- a/package/oprofile/oprofile-0.9.4-001-avr32-enable-lookup_dcookie.patch
+++ b/package/oprofile/oprofile-0.9.7-001-avr32-enable-lookup_dcookie.patch
diff --git a/package/oprofile/oprofile-0.9.4-002-no-query-modules.patch b/package/oprofile/oprofile-0.9.7-002-no-query-modules.patch
index 9f00da641..9f00da641 100644
--- a/package/oprofile/oprofile-0.9.4-002-no-query-modules.patch
+++ b/package/oprofile/oprofile-0.9.7-002-no-query-modules.patch
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index ae4cddeb1..734839f24 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -3,25 +3,26 @@
# oprofile
#
#############################################################
-OPROFILE_VERSION := 0.9.6
-OPROFILE_CONF_OPT := --localstatedir=/var \
- --with-kernel-support
-OPROFILE_BINARIES := utils/ophelp
-OPROFILE_BINARIES += pp/opannotate pp/oparchive pp/opgprof pp/opreport opjitconv/opjitconv
-OPROFILE_BINARIES += daemon/oprofiled
+OPROFILE_VERSION = 0.9.7
+OPROFILE_CONF_OPT = --localstatedir=/var --with-kernel-support
+OPROFILE_BINARIES = utils/ophelp pp/opannotate pp/oparchive pp/opgprof
+OPROFILE_BINARIES += pp/opreport opjitconv/opjitconv daemon/oprofiled
+ifeq ($(BR2_i386),y)
+OPROFILE_ARCH = i386
+endif
ifeq ($(BR2_powerpc),y)
-OPROFILE_ARCH := ppc
+OPROFILE_ARCH = ppc
endif
ifeq ($(BR2_x86_64),y)
-OPROFILE_ARCH := x86-64
+OPROFILE_ARCH = x86-64
endif
ifeq ($(OPROFILE_ARCH),)
-OPROFILE_ARCH := $(BR2_ARCH)
+OPROFILE_ARCH = $(BR2_ARCH)
endif
-OPROFILE_DEPENDENCIES := popt binutils
+OPROFILE_DEPENDENCIES = popt binutils
define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin