summaryrefslogtreecommitdiffstats
path: root/package/oprofile
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-12-31 08:39:04 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-02 22:55:36 +0100
commit243add5abc6491db5faa079d77ff077700c59077 (patch)
tree9a3d8efaa2ce9dc59b6f27f4ffd79580aaeb2f2e /package/oprofile
parent5bd272eb6bdd85c2de7ee1405058dbb0131b8beb (diff)
downloadbuildroot-novena-243add5abc6491db5faa079d77ff077700c59077.tar.gz
buildroot-novena-243add5abc6491db5faa079d77ff077700c59077.zip
oprofile: use new libbfd option
Convert the oprofile target to select the new libbfd staging/target option to avoid a huge target binutils for a simple task. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/oprofile')
-rw-r--r--package/oprofile/Config.in1
-rw-r--r--package/oprofile/oprofile.mk5
2 files changed, 2 insertions, 4 deletions
diff --git a/package/oprofile/Config.in b/package/oprofile/Config.in
index c877daee3..0e3652d39 100644
--- a/package/oprofile/Config.in
+++ b/package/oprofile/Config.in
@@ -5,6 +5,7 @@ config BR2_PACKAGE_OPROFILE
# choosen in the config. This will have to be fixed later.
depends on !BR2_TOOLCHAIN_EXTERNAL
select BR2_PACKAGE_POPT
+ select BR2_PACKAGE_BINUTILS
depends on BR2_INSTALL_LIBSTDCPP
help
OProfile is a system-wide profiler for Linux systems,
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index 3be50f28b..42bf0e257 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -5,9 +5,6 @@
#############################################################
OPROFILE_VERSION := 0.9.4
OPROFILE_CONF_OPT := --localstatedir=/var \
- --with-extra-includes="$(BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)-target/bfd \
- -I$(TOOLCHAIN_DIR)/binutils-$(BR2_BINUTILS_VERSION)/include" \
- --with-extra-libs=$(BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)-target/bfd \
--with-kernel-support
OPROFILE_BINARIES := utils/ophelp
@@ -24,7 +21,7 @@ ifeq ($(OPROFILE_ARCH),)
OPROFILE_ARCH := $(BR2_ARCH)
endif
-OPROFILE_DEPENDENCIES := popt binutils_target
+OPROFILE_DEPENDENCIES := popt binutils
define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin