summaryrefslogtreecommitdiffstats
path: root/package/oprofile/oprofile.mk
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-21 07:09:41 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-21 07:09:41 +0000
commit6e20da741b77f3e5c9b8a96e3101fcc4ab9cfee2 (patch)
tree358f20bb2914d10383dd81161184379de96bc50b /package/oprofile/oprofile.mk
parent98186f1d474b5dcc2cd32d5b6d7194c2ec385b5d (diff)
downloadbuildroot-novena-6e20da741b77f3e5c9b8a96e3101fcc4ab9cfee2.tar.gz
buildroot-novena-6e20da741b77f3e5c9b8a96e3101fcc4ab9cfee2.zip
Remove reference to query_modules in oprofile, does not exist in linux-2.6. oprofile now builds for ARM
Diffstat (limited to 'package/oprofile/oprofile.mk')
-rw-r--r--package/oprofile/oprofile.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index 066dbd2e7..ee6be3dc1 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -4,10 +4,11 @@
#
#############################################################
OPROFILE_VERSION := 0.9.4
-OPROFILE_CONF_OPT := --localstatedir=/var \
- --with-extra-includes="$(BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)-target/bfd -I$(TOOL_BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)/include" \
- --with-extra-libs=$(BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)-target/bfd \
- --with-kernel-support
+OPROFILE_CONF_OPT := --localstatedir=/var \
+ --with-extra-includes="$(BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)-target/bfd \
+ -I$(TOOL_BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)/include" \
+ --with-extra-libs=$(BUILD_DIR)/binutils-$(BR2_BINUTILS_VERSION)-target/bfd \
+ --with-kernel-support
OPROFILE_BINARIES := utils/ophelp
OPROFILE_BINARIES += pp/opannotate pp/oparchive pp/opgprof pp/opreport opjitconv/opjitconv
@@ -43,3 +44,4 @@ $(OPROFILE_TARGET_CLEAN):
rm -rf $(TARGET_DIR)/usr/share/oprofile
-$(MAKE) -C $(OPROFILE_DIR) clean
touch $@
+