summaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-15 06:39:15 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-15 21:37:47 +0100
commit3d680bf0dd0bd0f62dad91c9bf8c7657ebc5f59b (patch)
tree68269f1bfc9c5579b325703dd9624a06fbda6b50 /package/opkg
parent4cf256ec4943fe35f488238dc90fd45ff509a783 (diff)
downloadbuildroot-novena-3d680bf0dd0bd0f62dad91c9bf8c7657ebc5f59b.tar.gz
buildroot-novena-3d680bf0dd0bd0f62dad91c9bf8c7657ebc5f59b.zip
opkg: fix configure step by adding host-pkgconf dependency
The opkg configure.ac uses the PKG_CHECK_MODULES() m4 macro, which is provided by the .m4 files installed by host-pkgconf, so we must have this package as a dependency. Fixes: http://autobuild.buildroot.org/results/069fcab6e7dd5a1f07251ba6f52f65643a2f7594/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/opkg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/opkg/opkg.mk b/package/opkg/opkg.mk
index 3ba61aea4..9932d3f8b 100644
--- a/package/opkg/opkg.mk
+++ b/package/opkg/opkg.mk
@@ -11,6 +11,8 @@ OPKG_SITE_METHOD = svn
OPKG_INSTALL_STAGING = YES
OPKG_CONF_OPT = --disable-curl --disable-gpg
OPKG_AUTORECONF = YES
+# Uses PKG_CHECK_MODULES() in configure.ac
+OPKG_DEPENDENCIES = host-pkgconf
# Ensure directory for lockfile exists
define OPKG_CREATE_LOCKDIR