summaryrefslogtreecommitdiffstats
path: root/package/openvpn
diff options
context:
space:
mode:
authorValentine Barshak <gvaxon@gmail.com>2012-09-30 10:43:58 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-08 21:55:23 +0200
commitf02d58ccffa9be5d27dea4f13d690af1df9a96b9 (patch)
treedc5e6b7c43bf510bd3b63ef7156d70b3953ffb9b /package/openvpn
parente856daa89157bb31d2a88abb23542a65e4d0fbaa (diff)
downloadbuildroot-novena-f02d58ccffa9be5d27dea4f13d690af1df9a96b9.tar.gz
buildroot-novena-f02d58ccffa9be5d27dea4f13d690af1df9a96b9.zip
openvpn: Fix paths to external utilities
This sets paths to ifconfig, route, netstat and ip in the target root filesystem. Otherwise the paths leak from the host and may not match those on the target. Signed-off-by: Valentine Barshak <gvaxon@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openvpn')
-rw-r--r--package/openvpn/openvpn.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 03eabcf02..1c6e6ecdf 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -6,7 +6,16 @@
OPENVPN_VERSION = 2.2.2
OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
-OPENVPN_CONF_OPT = --enable-small --disable-plugins
+OPENVPN_CONF_OPT = --enable-small --disable-plugins \
+ --with-ifconfig-path=/sbin/ifconfig \
+ --with-route-path=/sbin/route \
+ --with-netstat-path=/bin/netstat
+
+ifeq ($(BR2_PACKAGE_IPROUTE2),y)
+OPENVPN_CONF_OPT += --with-iproute-path=/sbin/ip
+else
+OPENVPN_CONF_OPT += --with-iproute-path=/bin/ip
+endif
ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
OPENVPN_DEPENDENCIES += lzo