summaryrefslogtreecommitdiffstats
path: root/package/openvpn
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-23 21:54:24 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-23 22:09:25 +0200
commitabbd7223b23252d718b379c2a7345038b4a159eb (patch)
tree34e86d02a83699f8611c05a8dc85bf351af8fc4b /package/openvpn
parenta9b783379271eccf0f9745a31cfa8cbbadf51c53 (diff)
downloadbuildroot-novena-abbd7223b23252d718b379c2a7345038b4a159eb.tar.gz
buildroot-novena-abbd7223b23252d718b379c2a7345038b4a159eb.zip
openvpn: bump version, fix build with --disable-crypto
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openvpn')
-rw-r--r--package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch30
-rw-r--r--package/openvpn/openvpn.mk2
2 files changed, 31 insertions, 1 deletions
diff --git a/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch b/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch
new file mode 100644
index 000000000..546655875
--- /dev/null
+++ b/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch
@@ -0,0 +1,30 @@
+[PATCH] fix build with --disable-crypto
+
+options.c is missing the definition for struct context when built with
+--disable-crypto, as it then doesn't get pulled in through push.h,
+leading to build errors like:
+
+options.c: In function ‘parse_http_proxy_fallback’:
+options.c:1474: error: dereferencing pointer to incomplete type
+options.c:1477: error: dereferencing pointer to incomplete type
+options.c:1478: error: dereferencing pointer to incomplete type
+
+Fix it by including forward.h
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ options.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: openvpn-2.1.3/options.c
+===================================================================
+--- openvpn-2.1.3.orig/options.c
++++ openvpn-2.1.3/options.c
+@@ -29,6 +29,7 @@
+
+ #include "syshead.h"
+
++#include "forward.h"
+ #include "buffer.h"
+ #include "error.h"
+ #include "common.h"
diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 8d99cab21..7d8fb0c6f 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -4,7 +4,7 @@
#
#############################################################
-OPENVPN_VERSION = 2.1.2
+OPENVPN_VERSION = 2.1.3
OPENVPN_SITE = http://openvpn.net/release
OPENVPN_CONF_OPT = --enable-small