summaryrefslogtreecommitdiffstats
path: root/package/openswan
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-24 21:51:55 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-25 08:57:15 +0100
commitcdae2b24f01281c830ac74bc3818fa1773a59ea8 (patch)
treed90cd0547c8b6c111d25674e0bca04ffffedfae7 /package/openswan
parent48465f0796b0ffc53300161b746ff20ccce1e8df (diff)
downloadbuildroot-novena-cdae2b24f01281c830ac74bc3818fa1773a59ea8.tar.gz
buildroot-novena-cdae2b24f01281c830ac74bc3818fa1773a59ea8.zip
openswan: add missing TARGET_MAKE_ENV
openswan needs host-bison. The dependency was already there, but the build was not executed with $(TARGET_MAKE_ENV) in the environment, and therefore $(HOST_DIR)/usr/bin was not in the PATH. While we're at it, add licensing informations to openswan. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openswan')
-rw-r--r--package/openswan/openswan.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/openswan/openswan.mk b/package/openswan/openswan.mk
index 781dc0041..153d6590f 100644
--- a/package/openswan/openswan.mk
+++ b/package/openswan/openswan.mk
@@ -6,6 +6,9 @@
OPENSWAN_VERSION = 2.6.38
OPENSWAN_SITE = http://download.openswan.org/openswan
+OPENSWAN_LICENSE = GPLv2+, BSD-3c
+OPENSWAN_LICENSE_FILES = COPYING LICENSE
+
OPENSWAN_DEPENDENCIES = host-bison gmp iproute2
OPENSWAN_MAKE_OPT = ARCH=$(BR2_ARCH) CC="$(TARGET_CC)" \
USERCOMPILE="$(TARGET_CFLAGS)" INC_USRLOCAL=/usr \
@@ -25,11 +28,13 @@ endif
endif
define OPENSWAN_BUILD_CMDS
- $(MAKE) -C $(@D) $(OPENSWAN_MAKE_OPT) programs
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+ $(OPENSWAN_MAKE_OPT) programs
endef
define OPENSWAN_INSTALL_TARGET_CMDS
- $(MAKE) -C $(@D) $(OPENSWAN_MAKE_OPT) DESTDIR=$(TARGET_DIR) install
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+ $(OPENSWAN_MAKE_OPT) DESTDIR=$(TARGET_DIR) install
endef
$(eval $(generic-package))