summaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-04-28 18:30:20 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-04-28 18:30:20 +0000
commita4c8130640da5b989d3cdb861a438f639499413a (patch)
tree8c94ddb8e08a2762c2ad502e7712ca453fef88ca /package/openssl
parent32c9952c3fb7195ddac03e04964a69b5b57874d6 (diff)
downloadbuildroot-novena-a4c8130640da5b989d3cdb861a438f639499413a.tar.gz
buildroot-novena-a4c8130640da5b989d3cdb861a438f639499413a.zip
package/openssl: fix uninstall
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index a238ce859..a0e6f7e54 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -73,3 +73,11 @@ else
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/engines/lib*.so
endif
touch $@
+
+$(OPENSSL_TARGET_UNINSTALL):
+ $(call MESSAGE,"Uninstalling")
+ rm -rf $(addprefix $(TARGET_DIR)/,etc/ssl usr/bin/openssl usr/include/openssl)
+ rm -rf $(addprefix $(TARGET_DIR)/usr/lib/,ssl engines libcrypto* libssl* pkgconfig/libcrypto.pc)
+ rm -rf $(addprefix $(STAGING_DIR)/,etc/ssl usr/bin/openssl usr/include/openssl)
+ rm -rf $(addprefix $(STAGING_DIR)/usr/lib/,ssl engines libcrypto* libssl* pkgconfig/libcrypto.pc)
+ rm -f $(OPENSSL_TARGET_INSTALL_TARGET) $(OPENSSL_HOOK_POST_INSTALL)