summaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-15 07:28:06 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-15 07:28:06 +0000
commit740cf88151d43a5123fc9c9e8c09211efe610771 (patch)
treedaac9cca2ac7cf7f41d242747f320c8588b1c818 /package/openssl
parent59b0aa7a7ee327688a77dd5d01d0b2032f6535a2 (diff)
downloadbuildroot-novena-740cf88151d43a5123fc9c9e8c09211efe610771.tar.gz
buildroot-novena-740cf88151d43a5123fc9c9e8c09211efe610771.zip
openssl: strip libraries
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 67326902c..e7da3cdc2 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -58,10 +58,16 @@ $(OPENSSL_HOOK_POST_INSTALL):
ifeq ($(BR2_PACKAGE_OPENSSL_BIN),y)
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/bin/openssl
else
+ # libraries gets installed read only, so strip fails
+ for i in $(addprefix $(TARGET_DIR)/usr/lib/,libcrypto.so.* libssl.so.*); \
+ do chmod +w $$i; $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $$i; done
rm -f $(TARGET_DIR)/usr/bin/c_rehash
rm -f $(TARGET_DIR)/usr/bin/openssl
endif
ifneq ($(BR2_PACKAGE_OPENSSL_ENGINES),y)
rm -rf $(TARGET_DIR)/usr/lib/engines
+else
+ chmod +w $(TARGET_DIR)/usr/lib/engines/lib*.so
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/engines/lib*.so
endif
touch $@