summaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-03-14 14:33:48 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-04-01 21:56:21 +0200
commit47736c88c3dcc7ec4906bbb80acb194d2211b0c9 (patch)
tree21ace74f852fe4e1df50122c07d7b32906dfd609 /package/openssl
parent6bbd5367a59b9b98b48e06c3b489476834cfb220 (diff)
downloadbuildroot-novena-47736c88c3dcc7ec4906bbb80acb194d2211b0c9.tar.gz
buildroot-novena-47736c88c3dcc7ec4906bbb80acb194d2211b0c9.zip
openssl: fix compilation for i386
Closes #3445. OpenSSL emits bswap instructions when building for i386 targets which unfortunately is only available on 486+ class processors. Since the normal workaround is detected at build time and we are cross compiling we need to specify this. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 7bf347ad8..0163ef847 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -39,6 +39,11 @@ ifeq ($(ARCH),x86_64)
OPENSSL_TARGET_ARCH = x86_64
endif
+# Workaround for bug #3445
+ifeq ($(BR2_x86_i386),y)
+ OPENSSL_TARGET_ARCH = generic32 386
+endif
+
define OPENSSL_CONFIGURE_CMDS
(cd $(@D); \
$(TARGET_CONFIGURE_ARGS) \